View Issue Details

IDProjectCategoryView StatusLast Update
0000607XdebugRemote Debuggingpublic2017-01-03 18:56
ReporterishtanzarAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000607: Xdebug cannot handle the use of the passthru function
DescriptionI'm debugging a php script step by step that call another script using the passthru function but Xdebug crashes when calling it and the execution of the script is aborded.
TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

derick

2010-08-13 08:21

administrator   ~0001552

Please provide:
- a short example that demonstrates the issue
- the output of your remote debug log: http://xdebug.org/docs/remote#remote_log
- a gdb backtrace of the crash: http://bugs.php.net/bugs-generating-backtrace.php (under "If you can't get a core file")

ishtanzar

2010-08-13 09:36

reporter   ~0001559

Last edited: 2010-08-13 09:37

Steps To Reproduce :

parentScript.php:
<?php
echo "Hello World\n";
passthru('php childScript.php');

childScript.php:
<?php

echo "What's up ?\n";

run parentScript.php with Xdebug active.

Remote debug log:

Log opened at 2010-08-13 09:37:46
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/pgmillon/workspace-php/lmDoctrineGuardPlugin/parentScript.php" language="PHP" protocol_version="1.0" appid="14914" idekey="netbeans-xdebug"><engine version="2.1.0rc2-dev"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2010 by Derick Rethans]]></copyright></init>

<- feature_set -i 2351 -n show_hidden -v 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2351" feature="show_hidden" success="1"></response>

<- feature_set -i 2352 -n max_depth -v 3
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2352" feature="max_depth" success="1"></response>

<- feature_set -i 2353 -n max_children -v 31
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="2353" feature="max_children" success="1"></response>

<- feature_get -i 2354 -n max_data
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="2354" feature_name="max_data" supported="1"><![CDATA[1024]]></response>

<- run -i 2355

I cannot get any backtrace, the execution of the script if simply frozen :/

derick

2016-12-12 00:18

administrator   ~0004031

Is this still a problem for you with the latest versions of PHP and Xdebug?

derick

2017-01-03 18:56

administrator   ~0004141

I could not reproduce this, and no feedback was given. I'm closing this issue, but feel free to reopen if this happens again.

Issue History

Date Modified Username Field Change
2010-08-13 07:42 ishtanzar New Issue
2010-08-13 07:42 ishtanzar PHP Version => 5.3.3
2010-08-13 07:42 ishtanzar Xdebug Version => 2.1.0
2010-08-13 08:21 derick Note Added: 0001552
2010-08-13 08:21 derick Status new => feedback
2010-08-13 09:36 ishtanzar Note Added: 0001559
2010-08-13 09:37 ishtanzar Note Edited: 0001559
2014-03-05 09:21 derick Assigned To => derick
2014-03-05 09:21 derick Status feedback => assigned
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)
2016-12-12 00:18 derick Note Added: 0004031
2016-12-12 00:19 derick Category (No Category) => Remote Debugging
2016-12-12 00:19 derick Status assigned => feedback
2017-01-03 18:56 derick Note Added: 0004141
2017-01-03 18:56 derick Status feedback => resolved
2017-01-03 18:56 derick Resolution open => unable to reproduce