View Issue Details

IDProjectCategoryView StatusLast Update
0000061XdebugUsage problems (Wrong Results)public2004-05-15 18:27
ReporterreppuliAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Product Version 
Target VersionFixed in Version 
Summary0000061: (win) fatal error: undefined function calls
DescriptionCall to undefined function xdebug_dump_function_trace().
Same with xdebug_start_profiling() and so forth.

Seems that nly the error reporting part of xdebug functionality gained on install: profiling non-working?
Additional InformationVanilla installation of 5.0.0rc2 + xdebux 2.0-dev
phpinfo() shows xdebug loaded fine.

**php.ini**

zend_extension_ts="installationdir/php_xdebug.dll"

xdebug.auto_profile = on
xdebug.auto_profile_mode = 5
xdebug.output_dir = "/tmp"
TagsNo tags attached.
Operating SystemWindows 2000
PHP Version5.0.0rc2

Activities

Tularis

2004-05-11 10:20

reporter   ~0000130

Last edited: 2004-05-11 17:05

Those functions were removed from XDebug some time ago while Derick works on a better implementation.

See: http://bugs.xdebug.org/bug_view_page.php?bug_id=0000048

(version 2 only!)

edited on: 2004-05-11 18:05

reppuli

2004-05-11 17:16

reporter   ~0000132

so only php v4 profiling atm.

derick

2004-05-15 18:27

administrator   ~0000133

Actually, xdebug 1.3 works fine for both PHP 4 and PHP 5. But this is not a bug as Xdebug 2.x will have different profiling (much better!!) support.

Issue History

Date Modified Username Field Change
2004-05-11 02:25 reppuli New Issue
2004-05-11 10:20 Tularis Note Added: 0000130
2004-05-11 17:05 Tularis Note Edited: 0000130
2004-05-11 17:16 reppuli Note Added: 0000132
2004-05-15 18:27 derick Status new => resolved
2004-05-15 18:27 derick Resolution open => no change required
2004-05-15 18:27 derick Assigned To => derick
2004-05-15 18:27 derick Note Added: 0000133
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)