View Issue Details

IDProjectCategoryView StatusLast Update
0000646XdebugUsage problems (Wrong Results)public2011-01-25 14:03
ReporterAIML_EngrAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformMac ServerOSOSXOS Version10.6.4
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000646: Xdebug causes PHP files to hang at load
DescriptionWhen Xdebug is enabled in the php.ini, server will not process any php files. The scripts will then time out, though normal html files run fine. Checking installed modules, php-m shows Xdebug under [Zend]. All other server operations seem normal.
Steps To ReproduceUn-comment zend_extension=... line in php.ini
Restart server.
Run php file from browser.
Page load will hang indefinitely until timeout.
Re-comment out zend_extension=... line in php.ini
Restart server.
Run php file from browser.
Page will load fine.
Additional InformationEnd of php.ini with Xdebug settings:

[Zend]
zend_extension="/usr/lib/php/extensions/no-debug-non-zts-20090626/xdebug.so";
xdebug.file_link_format="txmt://open?url=file://%f&line=%1";

xdebug.remote_enable=1
xdebug.remote_autostart=1
xdebug.remote_mode=req
xdebug.remote_host= myIP
xdebug.remote_port=9000
xdebug.remote_handler=dbgp
xdebug.profiler_enable=1

xdebug.var_display_max_depth=10
xdebug.var_display_max_data=1000
TagsNo tags attached.
Operating System
PHP Version5.3.2

Activities

derick

2011-01-02 18:02

administrator   ~0001623

I can't reproduce this; and I don't have this OS anywhere either. Check with strace, or the Mac equivalent, what's going on?

Issue History

Date Modified Username Field Change
2010-12-17 16:49 AIML_Engr New Issue
2011-01-02 18:02 derick Note Added: 0001623
2011-01-02 18:02 derick Assigned To => derick
2011-01-02 18:02 derick Status new => feedback
2011-01-25 14:03 derick Status feedback => resolved
2011-01-25 14:03 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)