View Issue Details

IDProjectCategoryView StatusLast Update
0000648XdebugInstallationpublic2011-01-15 13:23
ReporterstephenlAssigned Toderick 
PriorityhighSeveritymajorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformWindows 7OSUltimateOS Version64bit
Product Version 
Target VersionFixed in Version 
Summary0000648: Xdebug will not install
DescriptionTailored Installation Instructions report as follows

Summary
•Xdebug installed: no
•Server API: Apache 2.0 Handler
•Windows: yes - Compiler: MS VC6 - Architecture: x86
•Zend Server: no
•PHP Version: 5.3.4
•Zend API nr: 220090626
•PHP API nr: 20090626
•Debug Build: no
•Thread Safe Build: yes
•Configuration File Path: C:\Windows
•Configuration File: C:\Program Files (x86)\php\php.ini
•Extensions directory: C:\Program
Instructions
1.Download php_xdebug-2.1.0-5.3-vc6.dll
2.Move the downloaded file to C:\Program
3.Edit C:\Program Files (x86)\php\php.ini and add the line
zend_extension = C:\Program\php_xdebug-2.1.0-5.3-vc6.dll
4.Restart the webserver

I have tried installing as suggested above and the extension will not load

I have also replaced zend_extension with extension, this allows teh extension to load however phpinfo() reports XDEBUG NOT LOADED AS ZEND EXTENSION

Please advise where im going wrong, or is Xdebug incompatiable with Windows 7 64bit ?

TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

philmatu

2011-01-03 02:39

reporter   ~0001628

I have a very similar situation. I've posted to the CPanel
Forum https://forums.cpanel.net/f5/bug-report-pecl-related-181881.html#post746311

System: CentOS 5.5 x64 - PHP 5.3.4

The extension installs via command line
"pecl install xdebug"

But in PHP.ini, the extension is placed as:
extension="xdebug.so"

As CPanel's support technician pointed out, it should be:
zend_extension="PATH_TO_FILE/xdebug.so"

Changing this fixed the problems.

Thanks,
Phil

derick

2011-01-15 13:23

administrator   ~0001649

Please contact the mailinglist for support as this is not a bug. See http://xdebug.org/support.php#list

Issue History

Date Modified Username Field Change
2010-12-18 12:53 stephenl New Issue
2011-01-03 02:39 philmatu Note Added: 0001628
2011-01-15 13:23 derick Note Added: 0001649
2011-01-15 13:23 derick Status new => resolved
2011-01-15 13:23 derick Resolution open => no change required
2011-01-15 13:23 derick Assigned To => derick