View Issue Details

IDProjectCategoryView StatusLast Update
0000649XdebugInstallationpublic2011-01-10 21:51
ReporterscoopexAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionnot fixable 
PlatformLinuxOSSUSE SLES 11 / Ubuntu 10.10OS Version
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000649: Installation prefix not properly handeled
DescriptionI want to install xdebug to a dedicated directory without
using the root account.
The "--prefix" flag of "configure" is not handled properly.

This bug also causes to break the installation of phing using pear as non-root user user.
(Pear automatically downloads and installes xdebug)
Steps To ReproduceMy installation process:
---
export INSTALLDIR="/tmp/broken-xdebug"
export XDEBUG_RELEASE="2.1.0"

wget http://www.xdebug.org/files/xdebug-${XDEBUG_RELEASE}.tgz
tar zxf xdebug-${XDEBUG_RELEASE}.tgz
cd xdebug-${XDEBUG_RELEASE}
phpize
./configure --enable-xdebug --prefix=$INSTALLDIR/xdebug
make
make install
---

After invoking "make install" i get the following error message:
---
Installing shared extensions: /usr/lib/php5/20090626/
cp: cannot create regular file `/usr/lib/php5/20090626/#INST@12385#': Permission denied
make: *** [install-modules] Error 1
---
Additional InformationPatching the makefile after running the "configure", "make", "make install" by the following procedure can be used as a dirty workaround:

perl -i -pe "~s;^EXTENSION_DIR.*\$;EXTENSION_DIR = $INSTALLDIR/extensions/;" Makefile
TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

derick

2011-01-02 18:08

administrator   ~0001625

The configure script is created by PHP's phpize command; if the prefix option doesn't work, the bug is likely in that script. Please file a bug report at http://bugs.php.net

However, you don't need "make install" for Xdebug to work. You can just copy modules/xdebug.so after compilation to whatever location you want, and then use zend_extension=/full/path/to/xdebug.so

scoopex

2011-01-02 18:56

reporter   ~0001626

That`s bad - xdebug installation also fails while installing phpunit with coverage support without beeing root. (This is the source of my problem)

I discovered that setting the following environment variable would be a workaround:
--
make INSTALL_ROOT=/tmp/test install
--
I´m not very experienced extension development and the tools related to this - maybe you can provide some information about what should be the correct solution.

derick

2011-01-10 21:50

administrator   ~0001638

This is still not a bug, and let's not discuss support issues in the bug tracker (Feel free to write to the mailinglist!)

Issue History

Date Modified Username Field Change
2010-12-29 12:32 scoopex New Issue
2011-01-02 18:08 derick Note Added: 0001625
2011-01-02 18:08 derick Status new => resolved
2011-01-02 18:08 derick Resolution open => not fixable
2011-01-02 18:08 derick Assigned To => derick
2011-01-02 18:56 scoopex Note Added: 0001626
2011-01-02 18:56 scoopex Status resolved => feedback
2011-01-02 18:56 scoopex Resolution not fixable => reopened
2011-01-10 21:50 derick Note Added: 0001638
2011-01-10 21:51 derick Status feedback => resolved
2011-01-10 21:51 derick Resolution reopened => not fixable