View Issue Details

IDProjectCategoryView StatusLast Update
0000652XdebugInstallationpublic2011-01-06 16:41
ReportermaxaonAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformWindows x64OSWindows 7OS VersionUltimate x64
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000652: Unable to install
DescriptionUnable to install XDebug

phpinfo()
PHP Version 5.3.4
Compiler MSVC9 (Visual C++ 2008)
Architecture x86
PHP API 20090626
PHP Extension 20090626
Zend Extension 220090626
Zend Extension Build API220090626,TS,VC9
PHP Extension Build API20090626,TS,VC9
Thread Safety enabled

I tried
zend_extension_ts="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9.dll"
zend_extension="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9.dll"
zend_extension_ts="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9-nts-x86_64.dll"
zend_extension="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9-nts-x86_64.dll"
an of course restarted apache. In phpinfo i can't find xdebug extension
Additional InformationApache 2.2.17; PHP 5.3.4
TagsNo tags attached.
Operating SystemWindows 7 x64 Ultimate
PHP Version5.3.3

Activities

maxaon

2011-01-05 23:37

reporter   ~0001634

I don't how but when i changed
zend_extension="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9.dll"
to
zend_extension="C:/www/bin/PHP/ext/php_xdebug-2.1.0-5.3-vc9.dll"
and added
"C:\www\bin\PHP\ext\ZendDebugger.dll"
zend_extension_ts="C:\www\bin\PHP\ext\ZendDebugger.dll"
zend_debugger.allow_hosts=192.168.100.100, 127.0.0.1
zend_debugger.expose_remotely=always
then i stopped apache and started i found that Xdedug loaded.
And if i start apache with
zend_extension="C:\www\bin\PHP\ext\php_xdebug-2.1.0-5.3-vc9.dll"
everything is ok
Strange.

Issue History

Date Modified Username Field Change
2011-01-05 23:16 maxaon New Issue
2011-01-05 23:37 maxaon Note Added: 0001634
2011-01-06 16:41 derick Status new => resolved
2011-01-06 16:41 derick Resolution open => no change required
2011-01-06 16:41 derick Assigned To => derick