View Issue Details

IDProjectCategoryView StatusLast Update
0000656XdebugUsage problems (Wrong Results)public2011-02-17 21:19
ReporterjsimmsAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000656: Summary not written when script ended with "exit()"
DescriptionIt seems that there may still be a problem with scripts that are terminated prematurely using the "exit" keyword.

I must admit that I am not very knowledgeable when it comes to the inner workings of xdebug or cachegrind files, but the two bug reports listed below seem to highlight what I am experiencing:

http://bugs.xdebug.org/view.php?id=68
http://bugs.xdebug.org/view.php?id=631

I installed xdebug tonight and noticed that when viewing the results in webgrind, sometimes information would be missing. Quickly deduced that this information was only missing on pages that used the "exit" keyword.
Steps To ReproduceCreate a simple script that is terminated prematurely using the exit keyword. I used a page that had a single call to phpinfo(), followed by the exit keyword. The resulting cachegrind file lacks, what I am assuming, is the summary line that others have mentioned in previous reports.
Additional InformationApache/2.2.15 (Win32)
PHP 5.3.3
php_xdebug-2.1.0-5.3-vc6.dll (as instructed by the Tailored Installation Instructions)

This is the first time I have submitted a bug report. If I am missing some relevant information, please let me know and I will add it.
TagsNo tags attached.
Operating SystemWindows XP Home SP3
PHP Version5.3.3

Relationships

duplicate of 0000631 closedderick Summary not written when script ended with "exit()" 

Activities

jon

2011-02-12 18:14

reporter   ~0001673

I could also reproduce this with PHP 5.3.3 and xdebug 2.1.0.

This was fixed in rev. 3369 (http://bugs.xdebug.org/view.php?id=631). If you need this bug fix you'll want to install from source -- either checkout trunk or just apply the patch from ticket 631 to the 2.1.0 release.

jsimms

2011-02-12 19:06

reporter   ~0001674

Unfortunately, I think compiling a dll may be a little beyond me. Unless you have a link to a good tutorial? I guess I'll just have to wait for the Windows binaries on the site to be updated.

Thanks for letting me know Jon :)

derick

2011-02-17 19:59

administrator   ~0001677

@jsimms: I have some at http://xdebug.org/files/xdebug-latest.tgz which are from December 17th — but they should have the fix. Can you try?

jsimms

2011-02-17 21:18

reporter   ~0001678

Hi Derick,

I replaced the php_xdebug-2.1.0-5.3-vc6.dll file with the php_xdebug-2.1dev-5.3-vc6.dll and it seems to be working great. I've tested pages that use the "exit" keyword and the resulting cachegrind files appear to have all the relevant information. I also tried the 2.2dev DLL, and that is fine too.

Thanks for posting that DLL pack, I appreciate it :)

derick

2011-02-17 21:19

administrator   ~0001679

Great. Closing as a dup of 0000631 then.

cheers,
Derick

Issue History

Date Modified Username Field Change
2011-01-17 23:57 jsimms New Issue
2011-02-12 18:14 jon Note Added: 0001673
2011-02-12 19:06 jsimms Note Added: 0001674
2011-02-17 19:59 derick Note Added: 0001677
2011-02-17 21:18 jsimms Note Added: 0001678
2011-02-17 21:19 derick Note Added: 0001679
2011-02-17 21:19 derick Relationship added duplicate of 0000631
2011-02-17 21:19 derick Status new => resolved
2011-02-17 21:19 derick Resolution open => duplicate
2011-02-17 21:19 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)