View Issue Details

IDProjectCategoryView StatusLast Update
0000657XdebugUncategorizedpublic2012-04-27 23:53
Reportertrebly Assigned Toderick  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformPCOSWin XP OS VersionSP3
Product Version2.1.0 
Summary0000657: xdebug_print_function_stack( [ string message ] ) spread on 5 screens
DescriptionSince I have upgraded to setting \php_xdebug-2.1.0-5.3-vc6.dll into php.ini
the error tables used too for xdebug_print_function_stack( [ string message ] )
is displayed spread on six screens large. These tables are unusable.
It uses normally a table of the class=xdebug-error which I don't find anywhere (a *.css ? which should be referenced at the start of html code - written by a function at launch of xdebug). May be I missed something in documentation, but I used xdebug the last two year and never met this problem.
Versus the error-messages are generally good, but no large data are displayed.

The problem seem to be generated by long strings which are not split at the good length to fit the table with large of 100% of the screen (seen as near 10,000px to fill...)
Steps To ReproduceProbably launch functions into a soft with options which display for these functions the vars with very large strings (html generated without breaklines)
Additional InformationPhp 5.3.4
TagsNo tags attached.
Operating System
PHP Version5.3.3

Activities

derick

2011-01-24 12:25

administrator   ~0001650

Would you have a screenshot perhaps?

trebly

2011-01-26 11:09

reporter   ~0001651

Hi,
Sorry I could not answer earlier.
I got an example. In this there are long strings which spread the "table" out of the width of the display window (here full screen 1920x1200). Then the "table" used by xdebug is quite 170% larger than the screen.
When the text of vars is larger (can be 100ko with some generated html passed as parameters to a function) the vars are split and the window of xdebug stack then on near five full screens (I had no time to try to reproduce, because the xdebug_get_function_stack( ) had been suppress after bug solution found. So I could not reproduce immediately.
I join 6 screenshot which covers the xdebug table.

trebly

2011-01-26 11:21

reporter   ~0001652

Sorry, I have not found how to join files after the first report. The "add note" don't include the ability and obviously the first submit can't be edited and the synthesis line "attached files" don't include as "tag" a command to join new files ?.

derick

2011-01-26 11:44

administrator   ~0001653

I've enabled the upload file feature now. There is an "upload file" box.

trebly

2011-01-26 15:47

reporter  

trebly

2011-01-26 15:47

reporter  

trebly

2011-01-26 15:48

reporter  

trebly

2011-01-26 15:49

reporter  

trebly

2011-01-26 15:50

reporter  

trebly

2011-01-26 15:51

reporter  

trebly

2011-02-12 11:47

reporter   ~0001672

Did you found a solution ?
The problem is fully the capability to xdebug screen displays to split line at a defined value (this should be a parameter as xdebug.split_lines_length) this without breaking words (syntax components).

Yesterday I got an xdebug_print_function_stack with 33573 characters line length, (is quite saying that this is the max length of a table at 32768 characters) four lines of quite the same length and the remaining table containing the other data as code (no more than 100 characters length) and the left and right columns.

Can I hope a solution or a good workaround.

Thanks for an answer

Best regards

Trebly
B10212-01

derick

2012-03-12 16:41

administrator   ~0001973

Is this still a problem, and if so, does setting xdebug.var_display_max_data to 128 help?

derick

2012-04-27 23:53

administrator   ~0002109

And no feedback provided.

Issue History

Date Modified Username Field Change
2011-01-21 19:51 trebly New Issue
2011-01-24 12:25 derick Note Added: 0001650
2011-01-24 12:25 derick Assigned To => derick
2011-01-24 12:25 derick Status new => feedback
2011-01-26 11:09 trebly Note Added: 0001651
2011-01-26 11:09 trebly Status feedback => assigned
2011-01-26 11:21 trebly Note Added: 0001652
2011-01-26 11:44 derick Note Added: 0001653
2011-01-26 11:44 derick File Added: dead.letter
2011-01-26 11:44 derick File Deleted: dead.letter
2011-01-26 15:47 trebly File Added: B10126-01-Call_stack-spread-out-01.jpg
2011-01-26 15:47 trebly File Added: B10126-01-Call_stack-spread-out-02.jpg
2011-01-26 15:48 trebly File Added: B10126-01-Call_stack-spread-out-03.jpg
2011-01-26 15:49 trebly File Added: B10126-01-Call_stack-spread-out-04.jpg
2011-01-26 15:50 trebly File Added: B10126-01-Call_stack-spread-out-05.jpg
2011-01-26 15:51 trebly File Added: B10126-01-Call_stack-spread-out-06.jpg
2011-02-12 11:47 trebly Note Added: 0001672
2012-03-12 16:41 derick Note Added: 0001973
2012-03-12 16:41 derick Status assigned => feedback
2012-04-27 23:53 derick Note Added: 0002109
2012-04-27 23:53 derick Status feedback => resolved
2012-04-27 23:53 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized