View Issue Details

IDProjectCategoryView StatusLast Update
0000664XdebugUsage problems (Wrong Results)public2012-07-14 19:38
ReporternnmatveevAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.1.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0000664: xdebug crash: kernel: pid 98370 (httpd), uid 80: exited on signal 11
DescriptionThis bug is reported by one of the PhpStorm EAP users. It seems to be xdebug bug.
We send 'feature_set max_depth -v 0' before sending 'context_get' in order to speed up debugging and it cause this problem.

We cannot reproduce the problem in our test environment, but it is always reproducible on user side.

Log attached.

Related youtrack issue: http://youtrack.jetbrains.net/issue/WI-5092
Additional InformationFreeBSD 6.2, Apache apache-2.2.17, php52-5.2.17
TagsNo tags attached.
Operating SystemFreeBSD 6.2
PHP Version5.2.10

Activities

nnmatveev

2011-02-11 04:53

reporter  

xdebug.log (4,127 bytes)

nnmatveev

2011-02-11 05:02

reporter   ~0001670

From user comment:
The xdebug log indicates that the following dbg command gets sent: "<- feature_set -i 10 -n max_depth -v 0 ->"
If i patch the xdebug source to override max_depth -v 0 to max_depth -v 3 the debugging is working again.
Even if xdebug should not crash max_depth 0 does not seem to be correct.

nnmatveev

2011-02-11 15:55

reporter   ~0001671

From user comment:
xdebug_handler_dbgp.c
Add line 1546: if (options->max_depth == 0) options->max_depth =1;
Works for me - without the line the http process crashes.
(FreeBSD 6.2. RELASE, GCC 3.4.6)

derick

2011-03-10 20:51

administrator   ~0001687

If you have easy access to the index.php script; that'd make it easier for me to reproduce this issue.

derick

2012-06-27 21:14

administrator   ~0002303

Is this still an issue with the latest releases?

nnmatveev

2012-07-01 17:51

reporter   ~0002313

I can't reproduce it on the latest release.

derick

2012-07-01 18:05

administrator   ~0002314

All right; closing this one then.

Issue History

Date Modified Username Field Change
2011-02-11 04:53 nnmatveev New Issue
2011-02-11 04:53 nnmatveev File Added: xdebug.log
2011-02-11 05:02 nnmatveev Note Added: 0001670
2011-02-11 15:55 nnmatveev Note Added: 0001671
2011-03-10 20:51 derick Note Added: 0001687
2012-03-12 16:42 derick Target Version => 2.2.1
2012-06-27 21:14 derick Note Added: 0002303
2012-06-27 21:14 derick Assigned To => derick
2012-06-27 21:14 derick Status new => feedback
2012-07-01 17:51 nnmatveev Note Added: 0002313
2012-07-01 17:51 nnmatveev Status feedback => assigned
2012-07-01 18:05 derick Note Added: 0002314
2012-07-01 18:05 derick Status assigned => resolved
2012-07-01 18:05 derick Resolution open => unable to reproduce
2012-07-14 19:38 derick Fixed in Version => 2.2.1
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)