View Issue Details

IDProjectCategoryView StatusLast Update
0000672XdebugUsage problems (Wrong Results)public2014-06-14 10:33
ReporterMikhail KharitonovAssigned Toderick 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformOSWindows XP SP3OS Version
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000672: Suspension when class have descructor and property refer to $this
DescriptionSee php code.
Steps To Reproduce<?php
ini_set('display_errors', 1);
ini_set('error_reporting', E_ALL);

class Foo
{
    private $thisObj;
    public function __construct()
    {
        $this->thisObj = $this; // If remove this line - no bag
    }
    
    public function __destruct() // If remove this method - no bag
    {
    }
}

for ($i = 0; $i <= 200; $i++)
{
    new Foo();
}


print 'text';

// BUG: Fatal error: Maximum execution time of 30 seconds exceeded in xdebug_destructor.php on line 13
?>
Additional InformationPHP 5.2.14

php.ini:
zend_extension="php_xdebug_nts.dll"
xdebug.remote_enable=1
xdebug.remote_autostart=1
xdebug.profiler_enable=0
xdebug.profiler_output_dir="C:\TEMP\xdebug"
xdebug.auto_trace=0
xdebug.trace_output_dir="C:\TEMP\xdebug"
TagsNo tags attached.
Operating SystemWindows XP SP3
PHP Version5.2.10

Activities

derick

2011-03-11 13:59

administrator   ~0001688

When do you get the "suspension"? When you simple run this, or if you use a debugger with this?

Mikhail Kharitonov

2011-03-14 09:48

reporter   ~0001690

When simple run (open page in browser), with remote_autostart=1. May be required increase iterations count. For example, cycle with 5 iteration ($i <= 5) on my computer do not effect to this bug.

derick

2014-05-19 23:09

administrator   ~0002815

Is this still a problem with the latest version of xdebug?

derick

2014-06-14 10:33

administrator   ~0002848

Unable to reproduce, and no feedback provided. I'm closing this out, but feel free to reopen if you can provide the requested information.

Issue History

Date Modified Username Field Change
2011-03-11 13:24 Mikhail Kharitonov New Issue
2011-03-11 13:59 derick Note Added: 0001688
2011-03-11 13:59 derick Assigned To => derick
2011-03-11 13:59 derick Status new => feedback
2011-03-14 09:48 Mikhail Kharitonov Note Added: 0001690
2011-03-14 09:48 Mikhail Kharitonov Status feedback => assigned
2014-05-19 23:09 derick Note Added: 0002815
2014-05-19 23:09 derick Status assigned => feedback
2014-06-14 10:33 derick Note Added: 0002848
2014-06-14 10:33 derick Status feedback => resolved
2014-06-14 10:33 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)