View Issue Details

IDProjectCategoryView StatusLast Update
0000675XdebugFeature/Change requestpublic2016-12-04 19:13
ReporterngaurAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0000675: invoking trace from command line
Description
It's currently possible to invoke the profiler for command line php execution by setting an environment variable:

  XDEBUG_CONFIG="profiler_enable=1"

Can we have the same thing for "trace_enable=1"?

In general, the set of configuration values accessible from the command line should probably be reviewed.

Looking at xdebug_env_config() in xdebug.c, it looks pretty straightforward to implement. If people want to patch that for their own use they will have little trouble in doing so.
TagsNo tags attached.
Operating System
PHP Version5.3.6

Relationships

duplicate of 0000517 closedderick Add a function trace trigger like for the profiler 

Activities

ngaur

2011-04-12 23:50

reporter   ~0001722

Turns out this is quite easy. I've patched this for my own use, and the fix is part of the composite patch I've shared on bug 0000644

derick

2014-02-27 20:06

administrator   ~0002725

Hello Troels,

This is related to 0000644. It would be great if you could create a *separate* pull request against https://github.com/xdebug/xdebug than the bits for 0000644.

There is information at http://xdebug.org/contributing.php to provide some help with GIT. And feel free to talk to me on IRC or the mailinglist.

cheers,
Derick

derick

2016-12-04 19:13

administrator   ~0003931

This got added all the way back in Xdebug 2.2.0 already - in 2012 :-)

Issue History

Date Modified Username Field Change
2011-03-31 01:22 ngaur New Issue
2011-04-12 23:50 ngaur Note Added: 0001722
2014-02-27 20:06 derick Note Added: 0002725
2014-02-27 20:06 derick Assigned To => derick
2014-02-27 20:06 derick Status new => feedback
2016-12-04 19:13 derick Note Added: 0003931
2016-12-04 19:13 derick Relationship added duplicate of 0000517
2016-12-04 19:13 derick Status feedback => resolved
2016-12-04 19:13 derick Resolution open => duplicate