View Issue Details

IDProjectCategoryView StatusLast Update
0000683Xdebugpublic2011-09-25 22:28
Reportervslinko Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
PlatformMacOSMac OS XOS Version10.6
Summary0000683: Segfault in phpunit
DescriptionProgram received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_INVALID_ADDRESS at address: 0x0000000000000008
0x000000010034b262 in gc_remove_zval_from_buffer ()
TagsNo tags attached.
Operating System
PHP Version5.3.4

Activities

derick

2011-04-30 20:40

administrator   ~0001731

What makes you think this is in Xdebug?

vslinko

2011-04-30 20:44

reporter   ~0001733

When I disable xdebug extenstion all be ok.

derick

2011-05-01 21:44

administrator   ~0001735

I really need more information. This warning just shows that it happens in PHP's garbage collector, and it's quite possible that the issue is with that. Try turning it off by running PHP with:

php -dzend.enable_gc=0 yourscript.php

or by setting "zend.enable_gc=0" in php.ini

vslinko

2011-05-02 13:11

reporter   ~0001739

I can't repeat error, because my tests are changed.

derick

2011-09-25 22:28

administrator   ~0001810

Closing it then. Let me know if it re-occurs.

Issue History

Date Modified Username Field Change
2011-04-25 08:53 vslinko New Issue
2011-04-30 20:40 derick Note Added: 0001731
2011-04-30 20:40 derick Assigned To => derick
2011-04-30 20:40 derick Status new => feedback
2011-04-30 20:44 vslinko Note Added: 0001733
2011-04-30 20:44 vslinko Status feedback => assigned
2011-05-01 21:44 derick Note Added: 0001735
2011-05-01 21:44 derick Status assigned => feedback
2011-05-02 13:11 vslinko Note Added: 0001739
2011-05-02 13:11 vslinko Status feedback => assigned
2011-09-25 22:28 derick Note Added: 0001810
2011-09-25 22:28 derick Status assigned => resolved
2011-09-25 22:28 derick Resolution open => unable to reproduce
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)