View Issue Details

IDProjectCategoryView StatusLast Update
0000685XdebugUncategorizedpublic2012-03-07 20:48
Reporterkao98 Assigned Toderick  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionduplicate 
PlatformApache 2.2.17 / php 5.2.17 
Summary0000685: Xdebug's error handler messes up with fatal to exception error conversions with SoapClient
DescriptionI still encounter the bug 0000249 with SoapClient
Steps To Reproduce<?php
try {
    $client = new SoapClient("http://127.0.0.1:3615/Service.asmx?WSDL",array("exceptions" => true));
    var_dump($client);
}
catch (SoapFault $e) {
    var_dump($e);
}

/*
Without xdebug, the exception is correctly catched. But with xDebug v2.1.1 loaded, I have a Fatal error: SOAP-ERROR: Parsing WSDL: Couldn't load from 'http://127.0.0.1:3615/Service.asmx?WSDL' : failed to load external entity "http://127.0.0.1:3615/Service.asmx?WSDL".
*/
Tags609
Operating SystemWindows XP sp3
PHP Version5.2.10

Relationships

duplicate of 0000705 resolvedderick SoapClient constructor does not throw exception where it should 

Activities

kao98

2011-05-06 06:48

reporter   ~0001744

Last edited: 2011-05-06 06:48

Sorry, I didn't saw this was already reported as the 0000609

derick

2012-03-07 20:48

administrator   ~0001959

Duplicate of 0000705 (and others). This is now fixed (for 2.1.4 and 2.2.0).

Issue History

Date Modified Username Field Change
2011-04-28 09:07 kao98 New Issue
2011-05-06 06:47 kao98 Tag Attached: 609
2011-05-06 06:48 kao98 Note Added: 0001744
2011-05-06 06:48 kao98 Note Edited: 0001744
2012-03-07 20:48 derick Note Added: 0001959
2012-03-07 20:48 derick Relationship added duplicate of 0000705
2012-03-07 20:48 derick Status new => resolved
2012-03-07 20:48 derick Resolution open => duplicate
2012-03-07 20:48 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized