View Issue Details

IDProjectCategoryView StatusLast Update
0000705XdebugUncategorizedpublic2012-01-06 18:41
ReporterntosicAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformLinuxOSCent OSOS Version5.5
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000705: SoapClient constructor does not throw exception where it should
DescriptionI could not find version 2.1.1 in dropdown, so I selected 2.1.0

This is actually ticket duplicate of:
https://bugs.php.net/bug.php?id=34657

When using XDebug w/SoapClient it does not throw exceptions if
wrong WSDL url is passed in SoapClient constructor.

When XDebug module is disabled, i get exceptions catched
Steps To Reproduce   try{
  
            $client = new SoapClient(
                           http://wrong.wsdl.url?wsdl,
                            array(
                                'exceptions' => true, 'trace' => true),
                                'features' => SOAP_SINGLE_ELEMENT_ARRAYS)
            );
          
            }catch(Exception $e){
                die("something went wrong");
            }
TagsNo tags attached.
Operating SystemCent OS
PHP Version5.3.3

Relationships

duplicate of 0000609 closedderick Xdebug messe up with fatal to exception error conversions with PHP SoapClient 
has duplicate 0000685 resolvedderick Xdebug's error handler messes up with fatal to exception error conversions with SoapClient 

Activities

danielc

2012-01-06 18:03

reporter   ~0001891

Last edited: 2012-01-06 18:04

View 2 revisions

This is a reappearance of Bug 0000249.

derick

2012-01-06 18:41

administrator   ~0001892

Duplicate of 0000609, which I think I've fixed in master on github!

Issue History

Date Modified Username Field Change
2011-07-25 14:07 ntosic New Issue
2012-01-06 18:03 danielc Note Added: 0001891
2012-01-06 18:04 danielc Note Edited: 0001891 View Revisions
2012-01-06 18:41 derick Note Added: 0001892
2012-01-06 18:41 derick Relationship added duplicate of 0000609
2012-01-06 18:41 derick Status new => resolved
2012-01-06 18:41 derick Resolution open => duplicate
2012-01-06 18:41 derick Assigned To => derick
2012-03-07 20:48 derick Relationship added has duplicate 0000685
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized