View Issue Details

IDProjectCategoryView StatusLast Update
0000715XdebugUsage problems (Wrong Results)public2014-02-27 19:13
ReporterigalicAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000715: Xdebug in combination with Suhosin makes Apache httpd's children segfault
DescriptionWhen loading both, Xdebug and Suhosin into an Apache httpd the children will segfault as soon as a PHP site is accessed.
Steps To ReproduceNo coredump is left behind. A backtrace can only be retrieved from gdb --args /path/to/httpd -X -f /path/to/config
Additional Information
#0  0x00007ffff71a3497 in ?? () from /lib/x86_64-linux-gnu/libc.so.6
#1  0x00007ffff71a631e in malloc () from /lib/x86_64-linux-gnu/libc.so.6
0000002  0x00007ffff71ac2f2 in strdup () from /lib/x86_64-linux-gnu/libc.so.6
0000003  0x00007ffff248221c in xdebug_header_handler (h=0x7fffda74dbb0, op=SAPI_HEADER_ADD, s=0x7ffff8679880, tsrm_ls=0x7ffff8679640) at /tmp/pear/temp/xdebug/xdebug.c:1399
0000004  0x00007fffed790756 in suhosin_header_handler (sapi_header=0x7fffda74dbb0, op=SAPI_HEADER_ADD, sapi_headers=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/header.c:330
0000005  0x00007fffed790756 in suhosin_header_handler (sapi_header=0x7fffda74dbb0, op=SAPI_HEADER_ADD, sapi_headers=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/header.c:330
....
#47562 0x00007fffed790756 in suhosin_header_handler (sapi_header=0x7fffda74dbb0, op=SAPI_HEADER_ADD, sapi_headers=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/header.c:330
#47563 0x00007fffed790756 in suhosin_header_handler (sapi_header=0x7fffda74dbb0, op=SAPI_HEADER_ADD, sapi_headers=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/header.c:330
#47564 0x00007fffed790756 in suhosin_header_handler (sapi_header=0x7fffda74dbb0, op=SAPI_HEADER_ADD, sapi_headers=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/header.c:330
#47565 0x00007ffff5d00199 in sapi_header_op (op=SAPI_HEADER_ADD, arg=<value optimized out>, tsrm_ls=<value optimized out>) at /tmp/build/php53-zts/php-5.3.8/main/SAPI.c:759
#47566 0x00007ffff5d007eb in sapi_add_header_ex (header_line=0x7ffff87ba9f8 "Set-Cookie: 53e5a27794d58afc78393dcccef89ad1=enhvdlvlfvuj3op2mhe089q7t5; path=/", header_line_len=<value optimized out>, duplicate=0 '\000', 
    replace=<value optimized out>, tsrm_ls=<value optimized out>) at /tmp/build/php53-zts/php-5.3.8/main/SAPI.c:518
#47567 0x00007ffff5c15ba0 in php_session_send_cookie (tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/ext/session/session.c:1291
#47568 php_session_reset_id (tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/ext/session/session.c:1335
#47569 0x00007ffff5c1adae in php_session_start (tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/ext/session/session.c:1489
#47570 0x00007ffff5c1b73c in zif_session_start (ht=<value optimized out>, return_value=0x7ffff87bc430, return_value_ptr=<value optimized out>, this_ptr=<value optimized out>, return_value_used=<value optimized out>, 
    tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/ext/session/session.c:1887
#47571 0x00007ffff248209c in xdebug_execute_internal (current_execute_data=0x7ffff7ddd6e8, return_value_used=0, tsrm_ls=0x7ffff8679640) at /tmp/pear/temp/xdebug/xdebug.c:1336
#47572 0x00007fffed791e7f in suhosin_execute_internal (execute_data_ptr=0x7ffff7ddd6e8, return_value_used=0, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/execute.c:1673
#47573 0x00007ffff5dbfd99 in zend_do_fcall_common_helper_SPEC (execute_data=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:322
#47574 0x00007ffff5d820b5 in execute (op_array=0x7ffff87d9c78, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:107
#47575 0x00007ffff2483a97 in xdebug_execute (op_array=0x7ffff87d9c78, tsrm_ls=0x7ffff8679640) at /tmp/pear/temp/xdebug/xdebug.c:1274
#47576 0x00007fffed7949f0 in suhosin_execute_ex (op_array=0x7ffff87d9c78, zo=0, dummy=0, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/execute.c:585
#47577 0x00007ffff5dbfbcf in zend_do_fcall_common_helper_SPEC (execute_data=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:344
#47578 0x00007ffff5d820b5 in execute (op_array=0x7ffff87bd2e0, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:107
#47579 0x00007ffff2483a97 in xdebug_execute (op_array=0x7ffff87bd2e0, tsrm_ls=0x7ffff8679640) at /tmp/pear/temp/xdebug/xdebug.c:1274
#47580 0x00007fffed7949f0 in suhosin_execute_ex (op_array=0x7ffff87bd2e0, zo=0, dummy=0, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/execute.c:585
#47581 0x00007ffff5dbfbcf in zend_do_fcall_common_helper_SPEC (execute_data=<value optimized out>, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:344
#47582 0x00007ffff5d820b5 in execute (op_array=0x7ffff86976f0, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/Zend/zend_vm_execute.h:107
#47583 0x00007ffff2483a97 in xdebug_execute (op_array=0x7ffff86976f0, tsrm_ls=0x7ffff8679640) at /tmp/pear/temp/xdebug/xdebug.c:1274
#47584 0x00007fffed7949f0 in suhosin_execute_ex (op_array=0x7ffff86976f0, zo=0, dummy=0, tsrm_ls=0x7ffff8679640) at /tmp/build/php-suhosin/suhosin-0.9.32.1/execute.c:585
#47585 0x00007ffff5d573e5 in zend_execute_scripts (type=8, tsrm_ls=0x7ffff8679640, retval=0x0, file_count=3) at /tmp/build/php53-zts/php-5.3.8/Zend/zend.c:1308
#47586 0x00007ffff5cf74b2 in php_execute_script (primary_file=0x7fffda750c20, tsrm_ls=0x7ffff8679640) at /tmp/build/php53-zts/php-5.3.8/main/main.c:2299
#47587 0x00007ffff5df4812 in php_handler (r=0x7ffff866f690) at /tmp/build/php53-zts/php-5.3.8/sapi/apache2handler/sapi_apache2.c:673
#47588 0x00007ffff7fd43f3 in ap_run_handler (r=0x7ffff866f690) at config.c:158
#47589 ap_invoke_handler (r=0x7ffff866f690) at config.c:376
#47590 0x00007ffff7fe2850 in ap_process_request (r=0x7ffff866f690) at http_request.c:282
#47591 0x00007ffff7fdf538 in ap_process_http_connection (c=0x7ffff8669138) at http_core.c:190
#47592 0x00007ffff7fdb647 in ap_run_process_connection (c=0x7ffff8669138, csd=0x7ffff8668f20) at connection.c:43
#47593 ap_process_connection (c=0x7ffff8669138, csd=0x7ffff8668f20) at connection.c:190
#47594 0x00007ffff7fe9c19 in process_socket (thd=0x7ffff8259de0, dummy=<value optimized out>) at worker.c:544
#47595 worker_thread (thd=0x7ffff8259de0, dummy=<value optimized out>) at worker.c:894
#47596 0x00007ffff74c4d8c in start_thread () from /lib/x86_64-linux-gnu/libpthread.so.0
#47597 0x00007ffff721004d in clone () from /lib/x86_64-linux-gnu/libc.so.6
#47598 0x0000000000000000 in ?? ()
A debugging session is active.

        Inferior 1 [process 24011] will be killed.

Quit anyway? (y or n) 
TagsNo tags attached.
Operating SystemLinux
PHP Version5.3.6

Activities

derick

2014-02-27 19:13

administrator   ~0002689

This looks like a bug in Suhosin, it goes into an infinite loop because it doesn't detect that header handler is changed - and then runs out of stack space.

Issue History

Date Modified Username Field Change
2011-09-06 11:43 igalic New Issue
2011-09-06 11:48 igalic Additional Information Updated View Revisions
2011-09-06 11:49 igalic Additional Information Updated View Revisions
2014-02-27 19:13 derick Note Added: 0002689
2014-02-27 19:13 derick Status new => resolved
2014-02-27 19:13 derick Resolution open => not fixable
2014-02-27 19:13 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)