View Issue Details

IDProjectCategoryView StatusLast Update
0000737XdebugUsage problems (Wrong Results)public2014-06-14 10:33
ReportercsunnyAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformMac miniOSMac OSOS Version10.7
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000737: Breakpoint partial working on Virtualhost site
DescriptionMac OS 10.7 Lion
MAMP
Eclipse PDT
Xdebug

First thanks to the wonderful debugging tools. I used it to debug Drupal.
Okey, First I setup a dev site on MAMP default localhost:8888, all debugging works like a charm!
Then someday I use virtualhostx to add a virtual host at dev.example.com for another dev site, then something weird happened:
Breakpoint at index.php (which is drupal's only entry for all web request) works well.
All other breakpoints at other site files just been ignored.

I have check xdebug log, all the breakpoints are set well(PDT sends them all to xdebug). But just breakpoint at index.php has been 'hit'(break).

Basically I only setup the following :
xdebug.remote_enable = On
xdebug.remote_host = 127.0.0.1
I have also try xdebug.remote_connect_back = On and it seems no luck.

Maybe I missed something obvious?
Many thanks
TagsNo tags attached.
Operating System
PHP Version5.3.6

Activities

csunny

2011-10-20 10:06

reporter   ~0001845

Additional Infomationa:
The step feature works.
I can step into other php files from index.php.

derick

2014-05-19 23:10

administrator   ~0002817

Is this still a problem for you? And if so, could you attach your xdebug.log file? See http://xdebug.org/docs/remote#remote_log on how to make one

derick

2014-06-14 10:33

administrator   ~0002850

Unable to reproduce, and no feedback provided. I'm closing this out, but feel free to reopen if you can provide the requested information.

Issue History

Date Modified Username Field Change
2011-10-20 08:52 csunny New Issue
2011-10-20 10:06 csunny Note Added: 0001845
2014-05-19 23:10 derick Note Added: 0002817
2014-05-19 23:10 derick Assigned To => derick
2014-05-19 23:10 derick Status new => feedback
2014-06-14 10:33 derick Note Added: 0002850
2014-06-14 10:33 derick Status feedback => resolved
2014-06-14 10:33 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)