View Issue Details

IDProjectCategoryView StatusLast Update
0000738XdebugFeature/Change requestpublic2016-12-09 00:30
ReporternnmatveevAssigned Toderick 
PriorityhighSeverityfeatureReproducibilityhave not tried
Status resolvedResolutionwon't fix 
Product Version 
Target VersionFixed in Version 
Summary0000738: Provide an option to generare xdebug profiler snapshots in compressed format
DescriptionAt the moment Xdebug profiler generates snapshot in human-readable and thus very redundant format. If user use some GUI viewer for snapshots, the more compressed format would preferable, because snapshot can be located on the remote machine and require some kind of transfering (e.g. FTP).

It is also necessary that snapshot contains information about its format in the header
Additional Informationrelated issue from PhpStorm issue tracker - http://youtrack.jetbrains.net/issue/WI-7916
TagsNo tags attached.
Operating System
PHP Version5.3.8

Activities

derick

2016-12-09 00:30

administrator   ~0003972

The cachegrind format does not support this, and because it doesn't, I can't just compress the xdebug profiles as it would make it impossible to load them in kcachegrind.

Issue History

Date Modified Username Field Change
2011-10-24 21:38 nnmatveev New Issue
2016-12-09 00:30 derick Note Added: 0003972
2016-12-09 00:30 derick Status new => resolved
2016-12-09 00:30 derick Resolution open => won't fix
2016-12-09 00:30 derick Assigned To => derick