View Issue Details

IDProjectCategoryView StatusLast Update
0000745Xdebug(No Category)public2014-03-12 21:53
ReporteraaronromanAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformmacOSlionOS Version10.7.2
Product Version 
Target VersionFixed in Version 
Summary0000745: Debug variables do show, but too slow in eclipse
DescriptionOn eclipse with PHPEclipse and doing remote debug, variables shows too slow, in all debug steps and breakpoints. The variables spend around 5 - 10 seconds to show in screen.


Eclipse v3.7.1
PHPEclipse v 1.2.3
xDebug v2.1.1
PHP v5.3.6
Apache 2.2.17
Steps To ReproduceRemote debug with Eclipse.
Insert breakpoint
First step (10 seconds to show some variable)
and it continue with the same slowly speed
TagsNo tags attached.
Operating Systemmacos lion
PHP Version5.3.6

Activities

derick

2012-03-12 16:47

administrator   ~0001975

How do you know whether this is an Xdebug issue rather than an Eclipse issue?

derick

2012-04-27 23:52

administrator   ~0002107

Hello?

aaronroman

2012-04-28 15:55

reporter   ~0002115

Hi derick, sorry for my late reply.

It's possible that the problem is Eclipse, but we were trying with the same version (eclipse) on different OS, and we only had this problem in macos.

Let me know if I can help you in any other way.

Thank you

derick

2014-02-27 19:34

administrator   ~0002702

Show me that Xdebug is slowing things down. A wireshark dump will tell me, so please make one if you really believe this is an issue with Xdebug. I don't believe it is.

derick

2014-03-12 21:53

administrator   ~0002767

Closing this out as I can't reproduce it and no feedback was provided. Please re-open if this issue returns.

Issue History

Date Modified Username Field Change
2011-11-08 12:28 aaronroman New Issue
2012-03-12 16:47 derick Note Added: 0001975
2012-03-12 16:47 derick Assigned To => derick
2012-03-12 16:47 derick Status new => feedback
2012-04-27 23:52 derick Note Added: 0002107
2012-04-28 15:55 aaronroman Note Added: 0002115
2012-04-28 15:55 aaronroman Status feedback => assigned
2014-02-27 19:34 derick Note Added: 0002702
2014-02-27 19:34 derick Status assigned => feedback
2014-03-12 21:53 derick Note Added: 0002767
2014-03-12 21:53 derick Status feedback => resolved
2014-03-12 21:53 derick Resolution open => no change required
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)