View Issue Details

IDProjectCategoryView StatusLast Update
0000759XdebugUsage problems (Wrong Results)public2016-11-27 19:54
Reportertimofey.basanov@gmail.comAssigned Toderick 
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionnot fixable 
Product Version 
Target VersionFixed in Version 
Summary0000759: XDebug remote debug hangs when php file debugged calls another php file with auto_start enabled
DescriptionI have xdebug.remote_autostart enabled to be able to debug files not requested by user browser and this is essential for me.
In my index.php file there is request for another php file like md5('http://myserver/another.php'). When I'm stepping in debugger through index.php file when I reach this line execution hangs for timeout time and after that result of md5 function is false.
This means that under debugging index.php files behaves differently. And as time of execution of index.php is limited for several seconds by third party service it mades my service totally unavailable when it's under debug.
Steps To Reproduce1. Setup Apache with next files in www dir:

.htaccess:
php_value xdebug.remote_autostart 1
php_value xdebug.remote_enable 1

index.php:
<?php md5('http://localhost/another.php');

another.php:
<?php echo 1;

2. Configure client debugger accordingly.

3. Run browser at 'http://localhost/index.php'

Here you can see that execution hangs for dozens of seconds which is not acceptable.
TagsNo tags attached.
Operating SystemLinux
PHP Version5.2.10

Activities

derick

2016-11-27 19:54

administrator   ~0003800

This is very likely because some IDEs/ debugging clients do not allow or cater for more than one debugging connection at the same time - instead, they queue the incoming connections. This is not something that I can fix in Xdebug.

Issue History

Date Modified Username Field Change
2011-12-14 02:24 timofey.basanov@gmail.com New Issue
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-27 19:54 derick Note Added: 0003800
2016-11-27 19:54 derick Status new => resolved
2016-11-27 19:54 derick Resolution open => not fixable
2016-11-27 19:54 derick Assigned To => derick