View Issue Details

IDProjectCategoryView StatusLast Update
0000772XdebugUncategorizedpublic2012-03-07 19:43
Reportergms8994 Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Summary0000772: PDOExceptions cause xdebug to not print the starting HTML code properly
DescriptionThe code provided will cause XDebug to display the exception handler, but the opening <table> tag seems to be missing, causing the display to be difficult to read.
Steps To Reproduce<?php
 
$dbh = new PDO('mysql:host=localhost;dbname=test', 'glens', '');
$dbh->query('SELECT * from FOO');
$dbh = null;
TagsNo tags attached.
Operating SystemLinux (Ubuntu and Gentoo)
PHP Version5.3.6

Activities

derick

2012-02-02 10:55

administrator   ~0001900

Last edited: 2012-02-02 10:55

When I run this, I get:



<font size='1'><table class='xdebug-error' dir='ltr' border='1' cellspacing='0' cellpadding='1'>
<tr><th align='left' bgcolor='#f57900' colspan="5"><span style='background-color: #cc0000; color: #fce94f; font-size: x-large;'>( ! )</span> Fatal error: Uncaught exception 'PDOException' with message 'SQLSTATE[28000] [1045] Access denied for user 'glens'@'localhost' (using password: NO)' in <a style='color: black' href='xdebug://-@3'>-</a> on line 3</th></tr>
<tr><th align='left' bgcolor='#f57900' colspan="5"><span style='background-color: #cc0000; color: #fce94f; font-size: x-large;'>( ! )</span> PDOException: SQLSTATE[28000] [1045] Access denied for user 'glens'@'localhost' (using password: NO) in <a style='color: black' href='xdebug://-@3'>-</a> on line 3</th></tr>
<tr><th align='left' bgcolor='#e9b96e' colspan='5'>Call Stack</th></tr>
<tr><th align='center' bgcolor='#eeeeec'>#</th><th align='left' bgcolor='#eeeeec'>Time</th><th align='left' bgcolor='#eeeeec'>Memory</th><th align='left' bgcolor='#eeeeec'>Function</th><th align='left' bgcolor='#eeeeec'>Location</th></tr>
<tr><td bgcolor='#eeeeec' align='center'>1</td><td bgcolor='#eeeeec' align='center'>9.6583</td><td bgcolor='#eeeeec' align='right'>655424</td><td bgcolor='#eeeeec'>{main}( )</td><td title='-' bgcolor='#eeeeec'><a style='color: black' href='xdebug://-@0'>..(null):0</a></td></tr>
<tr><td bgcolor='#eeeeec' align='center'>2</td><td bgcolor='#eeeeec' align='center'>9.6583</td><td bgcolor='#eeeeec' align='right'>657240</td><td bgcolor='#eeeeec'>PDO->__construct( <span>'mysql:host=localhost;dbname=test'</span>, <span>'glens'</span>, <span>''</span> )</td><td title='-' bgcolor='#eeeeec'><a style='color: black' href='xdebug://-@3'>..(null):3</a></td></tr>
</table></font>

And this looks all right to me...

derick

2012-03-07 19:43

administrator   ~0001953

Considering resolved, as there was no more feedback and I can't reproduce it with the latest version.

Issue History

Date Modified Username Field Change
2012-02-01 17:25 gms8994 New Issue
2012-02-02 10:55 derick Note Added: 0001900
2012-02-02 10:55 derick Assigned To => derick
2012-02-02 10:55 derick Status new => feedback
2012-02-02 10:55 derick Note Edited: 0001900
2012-03-07 19:43 derick Note Added: 0001953
2012-03-07 19:43 derick Status feedback => resolved
2012-03-07 19:43 derick Resolution open => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized