MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000777XdebugUsage problems (Wrong Results)public2012-02-13 15:382012-04-23 19:03
ReporterJim Bacon 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionfixed 
PlatformXAMPP 1.7.7OSWindowsOS VersionXP SP3
Product Version 
Target VersionFixed in Version2.1.4 
Summary0000777: Connection to NetBeans Reset on stepping over call to mysqli_init
DescriptionUsing XDebug 2.1.1 supplied with XAMPP and Netbeans 7.1 I have no problem.

I upgraded to XDebug 2.1.3-5.3-vc9 and could no longer debug my scripts because the connection to NetBeans would reset after hitting a breakpoint.

I found that the connection would always break after a call to mysqli_init().
Steps To Reproduce1. Create the script below.

<?php
   if (!function_exists('mysqli_init') && !extension_loaded('mysqli')) {
      echo('MySQLi extension for PHP is not installed. ');
   } else {
      $connection = mysqli_init();
      var_dump($connection);
   }
?>

2. Set a break point on call to mysqli_init()
3. Run debug.
4. On break, F8 to step to the next line.
5. The connection is reset and debug session aborted.
Additional InformationUpgraded from PHP 5.3.8 to 5.3.10 problem remained.
Downgraded to XDebug 2.1.1 to continue working.

TagsNo tags attached.
Operating SystemWindows XP SP3
PHP Version5.3.8
Attached Files? file icon xdebug_remote_log [^] (22,268 bytes) 2012-02-13 15:55 [Show Content]
txt file icon xdebug_remote_log_2.1dev.txt [^] (21,898 bytes) 2012-02-23 09:42 [Show Content]
gif file icon xdebug_screenshot_2.1dev.gif [^] (68,009 bytes) 2012-02-23 09:44


txt file icon xdebug_logs_mysqli_init_20120228.txt [^] (5,223 bytes) 2012-02-28 08:21 [Show Content]

- Relationships

-  Notes
(0001913)
derick (administrator)
2012-02-13 15:43

Hi Jim,

could you add a remote debugging log as described at http://xdebug.org/docs/all_settings#remote_log [^] ?

cheers,
Derick
(0001914)
Jim Bacon (reporter)
2012-02-13 15:57

Hi, Log added. Jim.
(0001915)
derick (administrator)
2012-02-13 22:51

Hi!

This crashes for me even when Xdebug is not loaded. I've file a bug report with PHP: https://bugs.php.net/bug.php?id=61079 [^]

cheers,
Derick
(0001916)
Jim Bacon (reporter)
2012-02-14 14:23

I think perhaps there are two issues then. The call to mysqli_init does not cause a problem with the released versions of PHP as far as I know.

I can run my scripts containing this function call.
I can run and debug them with XDebug 2.1.1.
I have just tried XDebug 2.1.2 and that also works for me.
I can run and debug scripts with XDebug 2.1.3 that do not contain that function call.

When I try to reproduce your bug report to PHP the -n option results in the function not being found as the mysqli module is not loaded.

Thanks for your great work, by the way, Jim.
(0001921)
derick (administrator)
2012-02-19 10:33

I think I managed to do a fix for this. Could you try the latest version from github?
(0001922)
Jim Bacon (reporter)
2012-02-21 09:36

If you can point me at a compiled version (5.3-vc9) I would gladly try it but I am not in a position to compile it from source myself.
(0001923)
derick (administrator)
2012-02-22 21:40

I've just put some up at : http://xdebug.org/files/xdebug-latest.tgz [^]
(0001926)
Jim Bacon (reporter)
2012-02-23 10:02

Great. Tried 2.1dev-5.3-vc9 and 2.2dev-5.3-vc9 with PHP 5.3.8. Both appear to fail in the same way as the release, 2.1.3-5.3.vc9.

Attached another remote log from tests with 2.1dev.

Additional information. On stepping over the call to mysqli_init an "Unhandled exception occurred in httpd.exe" message is received with an option to debug. Screenshot from debugger attached.
(0001928)
codewaggle (reporter)
2012-02-28 08:39

Hi,

I'm experiencing the same problem with xdebug version 2.1.3 on a LAMP with php5.3
I'm using netbeans 7.1 on a Win XP box to do remote debugging

mysqli_init causes a Segmentation fault when I step past it. If I run the code with no breakpoints, I don't see the Segmentation fault, but I still get the server reset error.

I have another LAMP server with php5.2.10 and xdebug 2.1.0. The exact same code runs without problems.

I've uploaded a file that has snippets from my apache error log and my xdebug log: xdebug_logs_mysqli_init_20120228.txt

Let me know if I can provide additional info that would be helpful.

Be Well,
Joe
(0001930)
derick (administrator)
2012-02-29 13:09

It's still crashing on the PHP bug: https://bugs.php.net/bug.php?id=61003 [^]

That's not something I can fix in Xdebug, so I'm closing this issue. Please add comments to the PHP bug to show you are having the same issue.
(0001941)
Jim Bacon (reporter)
2012-02-29 14:28

I just wanted to add a final note, then, to say that, from a user's perspective, the resolution to this problem is to use xdebug 2.1.2 until such time as the bug in PHP is fixed (or some change that must have been made in version 2.1.3, is reverted). I guess this also means that, even if PHP is fixed, xdebug 2.1.3 will never play nicely with the older versions of PHP. I am continuing very happily in this manner.
Thanks for your time and effort,
Jim.
(0001972)
derick (administrator)
2012-03-12 16:36

Thanks! And closing this issue.
(0002085)
derick (administrator)
2012-04-23 19:03

Seems like this is fixed in PHP as well now.

- Issue History
Date Modified Username Field Change
2012-02-13 15:38 Jim Bacon New Issue
2012-02-13 15:43 derick Note Added: 0001913
2012-02-13 15:43 derick Assigned To => derick
2012-02-13 15:43 derick Status new => feedback
2012-02-13 15:55 Jim Bacon File Added: xdebug_remote_log
2012-02-13 15:57 Jim Bacon Note Added: 0001914
2012-02-13 15:57 Jim Bacon Status feedback => assigned
2012-02-13 22:51 derick Note Added: 0001915
2012-02-13 22:51 derick Status assigned => resolved
2012-02-13 22:51 derick Resolution open => not fixable
2012-02-14 14:23 Jim Bacon Note Added: 0001916
2012-02-14 14:23 Jim Bacon Status resolved => feedback
2012-02-14 14:23 Jim Bacon Resolution not fixable => reopened
2012-02-19 10:33 derick Note Added: 0001921
2012-02-21 09:36 Jim Bacon Note Added: 0001922
2012-02-21 09:36 Jim Bacon Status feedback => assigned
2012-02-22 21:40 derick Note Added: 0001923
2012-02-23 09:42 Jim Bacon File Added: xdebug_remote_log_2.1dev.txt
2012-02-23 09:44 Jim Bacon File Added: xdebug_screenshot_2.1dev.gif
2012-02-23 10:02 Jim Bacon Note Added: 0001926
2012-02-28 08:21 codewaggle File Added: xdebug_logs_mysqli_init_20120228.txt
2012-02-28 08:39 codewaggle Note Added: 0001928
2012-02-29 13:09 derick Note Added: 0001930
2012-02-29 13:09 derick Status assigned => resolved
2012-02-29 13:09 derick Resolution reopened => not fixable
2012-02-29 14:28 Jim Bacon Note Added: 0001941
2012-02-29 14:28 Jim Bacon Status resolved => feedback
2012-02-29 14:28 Jim Bacon Resolution not fixable => reopened
2012-03-12 16:36 derick Note Added: 0001972
2012-03-12 16:36 derick Status feedback => closed
2012-03-12 16:36 derick Resolution reopened => fixed
2012-03-12 16:36 derick Fixed in Version => 2.1.4
2012-04-23 19:03 derick Note Added: 0002085
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker