View Issue Details

IDProjectCategoryView StatusLast Update
0000782XdebugUsage problems (Wrong Results)public2014-03-12 21:52
ReporterrsoniAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version2.1.0 
Target VersionFixed in Version 
Summary0000782: Memory Leak found when auto_trace is enabled
DescriptionI am using Apache Server with PHP and wrote a simple php "Hello World" program with 3 function calls in 3 files (1 call per file). Used jmeter to run load with 60 threads. There is a memory leak when we enable auto_trace (xdebug.auto_trace=1) and hit load against the application hosted on Apache Server.

When I disable auto_trace and run the same load, the memory is stable (becomes constant after a while).

This issue might be related to: http://bugs.xdebug.org/view.php?id=425
TagsNo tags attached.
Operating System
PHP Version5.3.8

Activities

rsoni

2012-03-11 23:52

reporter   ~0001966

Last edited: 2012-03-11 23:53

View 2 revisions

This issue goes away when I use emalloc instead of malloc in xdebug_mm.h, that is change #if 0 to #if 1

derick

2014-02-27 19:20

administrator   ~0002697

Is this issue still causing you problems?

derick

2014-03-12 21:52

administrator   ~0002766

Closing this out as I can't reproduce it and no feedback was provided. Please re-open if this issue returns.

Issue History

Date Modified Username Field Change
2012-02-28 03:29 rsoni New Issue
2012-03-11 23:52 rsoni Note Added: 0001966
2012-03-11 23:53 rsoni Note Edited: 0001966 View Revisions
2014-02-27 19:20 derick Note Added: 0002697
2014-02-27 19:20 derick Assigned To => derick
2014-02-27 19:20 derick Status new => feedback
2014-03-12 21:52 derick Note Added: 0002766
2014-03-12 21:52 derick Status feedback => resolved
2014-03-12 21:52 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)