View Issue Details

IDProjectCategoryView StatusLast Update
0000783XdebugInstallationpublic2012-04-27 23:51
Reportercapitan obvious Assigned Toderick  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx86_64OSUbuntuOS Version11.10
Product Version2.2dev 
Summary0000783: Cannot run with PHP v5.4RC8: undefined symbol: output_globals_id
DescriptionWhile starting php I get next error:
$ php -v
Failed loading /usr/lib/extensions/no-debug-zts-20090626/xdebug.so: /usr/lib/extensions/no-debug-zts-20090626/xdebug.so: undefined symbol: output_globals_id
PHP 5.4.0RC8 (cli) (built: Feb 27 2012 22:56:20)
Copyright (c) 1997-2012 The PHP Group
Zend Engine v2.4.0, Copyright (c) 1998-2012 Zend Technologies

(the same error while runnin as apache module)
Steps To Reproducerun `php -v`
Additional InformationI have compiled php 5.4rc8 with next configuration:
'./configure' '--prefix=/usr' '--enable-zip' '--with-apxs2=/usr/bin/apxs2' '--enable-sockets' '--enable-shmop' '--enable-sysvshm' '--enable-sysvsem' '--enable-sysvmsg' '--enable-pcntl' '--enable-shared=all' '--with-mysql' '--with-mysqli' '--with-mcrypt' '--enable-mbstring' '--enable-intl' '--with-gd' '--with-curl' '--with-zlib' '--with-openssl' '--with-regex' '--enable-fpm' '--with-config-file-path=/etc/php5' '--with-config-file-scan-dir=/etc/php5/conf.d'

And compiled xdebug from master git
'./configure' '--enable-xdebug' '--prefix=/usr' '--with-php-config=/usr/local/bin/php-config'

and included in php.ini as zend_extension
TagsNo tags attached.
Operating System
PHP Version5.4-dev

Activities

derick

2012-03-12 16:51

administrator   ~0001978

This error demonstrates that you use a non-ZTS version of the extension with a ZTS version of PHP, or something. Or perhaps your headers don't match your installed PHP version. Please refer to: http://xdebug.org/find-binary.php If that doesn't help, please provide the output of phpize and ./configure (for xdebug)

derick

2012-04-27 23:51

administrator   ~0002105

And no feedback provided.

Issue History

Date Modified Username Field Change
2012-02-28 20:33 capitan obvious New Issue
2012-03-12 16:51 derick Note Added: 0001978
2012-03-12 16:51 derick Assigned To => derick
2012-03-12 16:51 derick Status new => feedback
2012-04-27 23:51 derick Note Added: 0002105
2012-04-27 23:51 derick Status feedback => resolved
2012-04-27 23:51 derick Resolution open => unable to reproduce