View Issue Details

IDProjectCategoryView StatusLast Update
0000793XdebugInstallationpublic2012-04-27 23:57
ReportertimcriderAssigned Toderick 
PrioritynormalSeverityminorReproducibilitysometimes
Status resolvedResolutionno change required 
PlatformLinuxOSCentOSOS Version5.7
Product Version2.1.3 
Target VersionFixed in Version 
Summary0000793: PEAR segmentation fault on install
DescriptionThis is a duplicate of bug 0000364.
http://bugs.xdebug.org/view.php?id=364

The other bug is closed, but I have found a way to reproduce this error.

if xdebug.so already exists in the php module/extension directory, the PEAR installer will segfault and crash. This does not necessarily mean that the install failed, because the module is actually overwritten as you would expect. However, due to the segfault, the package is not marked as update and will continue to process during the next 'pear upgrade'.
TagsNo tags attached.
Operating System
PHP Version5.3.10

Activities

derick

2012-03-16 22:01

administrator   ~0001988

This is weird, because the pecl installer should run PHP with the -n option. Did you use "pear install xdebug" or "pecl install xdebug"?

timcrider

2012-03-16 22:20

reporter   ~0001993

This came through with a normal run of "pear upgrade".

1. pear upgrade picked up the update
2. download, configure, compile worked fine
3. Install message came up
4. Segfault

 When I did a php -i, it showed the new version of XDebug installed, but the pear updater itself tried to install it again next time I ran "pear upgrade".

 Only after I went into /path/to/php/extensions/ and moved xdebug.so to xdebug-old.so, and did a "pear upgrade", did it install and register without any issues.

This was on CentOS 5.8 on php 5.3.10.

derick

2012-03-16 22:23

administrator   ~0001994

Can you try "pecl upgrade xdebug" like this too? I don't think I can do anything about it though... it's something for the PEAR/PECL installer people.

timcrider

2012-03-16 22:31

reporter   ~0001995

"pecl upgrade -f xdebug" does a clean install, with no segfaults

For good measure I tried to do "pear upgrade -f xdebug", and got the following message:

No releases available for package "pear.php.net/xdebug" - package pecl/xdebug can be installed with "pecl install xdebug"
upgrade failed

 So it looks like this is limited to "pear upgrade". If you would like me to try something else, please let me know.

derick

2012-04-27 23:57

administrator   ~0002111

It's not something I can fix then, but it's for the PEAR installer people. However, I think they'll just say "use pecl install"...

Issue History

Date Modified Username Field Change
2012-03-13 15:03 timcrider New Issue
2012-03-16 22:01 derick Note Added: 0001988
2012-03-16 22:01 derick Assigned To => derick
2012-03-16 22:01 derick Status new => feedback
2012-03-16 22:20 timcrider Note Added: 0001993
2012-03-16 22:20 timcrider Status feedback => assigned
2012-03-16 22:23 derick Note Added: 0001994
2012-03-16 22:23 derick Status assigned => feedback
2012-03-16 22:31 timcrider Note Added: 0001995
2012-03-16 22:31 timcrider Status feedback => assigned
2012-04-27 23:57 derick Note Added: 0002111
2012-04-27 23:57 derick Status assigned => resolved
2012-04-27 23:57 derick Resolution open => no change required