View Issue Details

IDProjectCategoryView StatusLast Update
0000804Xdebugpublic2012-03-24 21:35
Reporterhermanradtke Assigned Toderick  
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformPHPOSCentOSOS Version6.2
Product Version2.1.0 
Summary0000804: cannot send stack_get on scripts with one line
DescriptionI created a simple script for hacking on the vim xdebug integration and noticed an error when the "stack_get" command was sent. If there is only 1 line in the script, the response from xdebug is an error.
Steps To ReproduceCreate the following script:

<?php

$a = array(array(1), array(2), array(3));

Send the commands in the attached xdebug.log file and noticed that when "stack_get" is sent an error is returned.
Additional InformationI can recreate on php-5.3.x and php-5.4.0 for xdebug versions >- 2.1.0
TagsNo tags attached.
Operating SystemCentOS 6.2
PHP Version5.3.8

Activities

hermanradtke

2012-03-24 06:19

reporter  

xdebug.log (1,854 bytes)

derick

2012-03-24 21:35

administrator   ~0002010

Hi Herman,

this is not a bug. After your first "step_into" you're at the line with the code. When you then issue "run" the script ends. The DBGp output signals that by "state=stopped". In the stopped state, the script no longer exists and hence stack_get means nothing.

If you have any more questions regarding to the DBGp protocol, send a mail to the dev list (xdebug-dev@lists.xdebug.org) — it's moderated though.

cheers,
Derick

Issue History

Date Modified Username Field Change
2012-03-24 06:19 hermanradtke New Issue
2012-03-24 06:19 hermanradtke File Added: xdebug.log
2012-03-24 21:35 derick Note Added: 0002010
2012-03-24 21:35 derick Status new => resolved
2012-03-24 21:35 derick Resolution open => no change required
2012-03-24 21:35 derick Assigned To => derick
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)