View Issue Details

IDProjectCategoryView StatusLast Update
0000810XdebugUncategorizedpublic2012-10-24 18:14
Reporterjos.norberg@gmail.comAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
PlatformwampOSwindowsOS Versionvista
Product Version2.2dev 
Target VersionFixed in Version 
Summary0000810: 2.2.0RC1-5.4-vc9.dll will not start debug session on php 5.4.0 ts
Descriptionif I try to invoke a debug session on PHPStorm or on NetBeans with 2.2.0RC1-5.4-vc9.dll I get a blank screen in FireFox & it tells me page loading is done. If I switch back to php_xdebug-2.1.4-5.3-vc9.dll everything functions as usual with the debugging session.
Steps To ReproduceUsing "PhpStorm 117.132" (same with NetBeans 6.8) start web application debug session. Breakpoints have been set. (This exact procedure produces a successful outcome btw with php_xdebug-2.1.4-5.3-vc9.dll). This initiates a transfer of focus to the web browser. It leaves a blank screen with the correct url in address bar including the ?XDEBUG_SESSION_START=15558 portion. FireFox reports the page as done. phpStorm reports "waiting for incoming connection with ide key '15558'
TagsNo tags attached.
Operating Systemwindows
PHP Version5.4.0

Activities

jos.norberg@gmail.com

2012-04-12 15:37

reporter   ~0002040

I found that if I used the server that comes with PHP 5.4 running on port 8000 I was able to successfully run a debugging session with this release--based on the rest of my WAMP stack being what it is.

meglio

2012-04-14 19:46

reporter   ~0002041

Last edited: 2012-04-14 19:48

View 3 revisions

I can't use with php 5.4 too, here is the maximum info I can get from crash alert:


Problem signature:
  Problem Event Name: APPCRASH
  Application Name: php.exe
  Application Version: 5.4.0.0
  Application Timestamp: 4f4e6fc7
  Fault Module Name: php_xdebug-2.2.0RC1-5.4-vc9.dll
  Fault Module Version: 2.2.0.1
  Fault Module Timestamp: 4f5f4cb3
  Exception Code: c0000005
  Exception Offset: 00018e6c
  OS Version: 6.1.7601.2.1.0.256.1
  Locale ID: 1058
  Additional Information 1: 0a9e
  Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
  Additional Information 3: 0a9e
  Additional Information 4: 0a9e372d3b4ad19135b953a78882e789



Windows 7, 64bit.
My php.ini file: http://pastie.org/private/mwxyp83utsjd3nemcvpsg

derick

2012-04-15 15:04

administrator   ~0002042

Jos,

do you know whether Xdebug is crashing?

Meglio,

it would be awesome if you could provide some more information. Have a look at https://bugs.php.net/bugs-generating-backtrace-win32.php under "Generating backtrace, without compiler, on Win32".

cheers,
Derick

coopster

2012-04-16 17:49

reporter   ~0002049

Derick, I'm experiencing the same exact behavior in Eclipse as Jos. No, it does not appear that Xdebug is crashing and I see no indication of that in any of the logs. As a matter of fact, it appears that all is well except that Xdebug is not breaking at any breakpoints. The debug session begins, the browser opens, the browser completes the entire script processing without stopping at any breakpoints. Back in the Eclipse editor, the Progress tab is showing the task as still launching and the message "Launching: waiting for XDebug session" is displayed. The only option at this point is to Terminate the session. Once that option is selected the debug session ends properly and displays the following message in the browser: DEBUG SESSION ENDED

It is as if Xdebug is not recognizing breakpoints?

meglio

2012-04-16 19:53

reporter   ~0002050

Derick, I'll do it tomorrow. Got no time to do it today.

Regards,
Anton

coopster

2012-04-17 00:09

reporter   ~0002051

As a test I attempted to use the Zend debugger, even thought the latest version is a PHP 5.2 thread-safe binary. The Zend debugger behaved the exact same. Now I am wondering if there isn't a PHP hook somewhere in here that has changed?

nnmatveev

2012-04-17 21:36

reporter   ~0002052

We have several related reports from PhpStorm users. Also the issue is always reproducible for me with Xdebug 2.2.0RC1 (with PHP5.3.8). It makes this version of Xdebug completely unusable.

Related thread from PhpStorm forum: http://devnet.jetbrains.net/message/5454601

nnmatveev

2012-04-17 21:43

reporter   ~0002053

Related thread from stackoverflow - http://stackoverflow.com/questions/10125216/phpstorm-xdebug-page-not-loading

derick

2012-04-22 12:50

administrator   ~0002064

I can't seem to reproduce this... I'll be rolling RC2 today that should fix a couple of problems.

derick

2012-04-22 15:30

administrator   ~0002071

Please try the just released Xdebug 2.2.0RC2, which I believe fixes this issue.

coopster

2012-04-22 18:28

reporter   ~0002073

Not yet, Derick :(
Same as RC1, not breaking at breakpoints.
I just pulled the RC2 down and added the new RC2 to my extensions directory, updated php.ini to point to the new RC2 and then I restarted the Apache server and opened Eclipse. I made sure that Xdebug was all set up and configured as the proper debugger and ran a test with the exact same results as RC1.

Is there anything I can do to help troubleshoot?

meglio

2012-04-27 10:02

reporter   ~0002098

I finally got success in setting up debugging tools, and I got full debug trace for that error that I still can reproduce.

Both .dmp and .htm files are here:
https://docs.google.com/open?id=0Bw2to3QgEte-bmZPREtRRXp4em8

NB. This error now happens with xdebug RC2 and when using with phpstorm 4.0.1

coopster

2012-04-30 16:47

reporter   ~0002117

I just pulled and installed the latest PHP 5.4.1 release to see if it was a PHP release issue or not but I still get the same results, no breakpoint stops.

dylfin

2012-05-11 13:53

reporter   ~0002142

Php 5.4.2 as module via php5apache2_4.dll for Apache 2.4.2.
xDebug 2.2.0RC2 almost worked for me, it just required 3-4 Apache's restarts during a day.
New version xDebug 2.2 crashed on object unserialize. I tried to create simple test to locate problem, but with simple objects it works without any problems.

Faulting application name: httpd.exe, version: 2.4.2.0, time stamp: 0x4f913756
Faulting module name: php_xdebug-2.2.0-5.4-vc9.dll, version: 2.2.0.5, time stamp: 0x4fa90762
Exception code: 0xc0000005

derick

2012-06-25 18:08

administrator   ~0002280

meglio, I can't do anything with those windows dump files. I could really do with a reproducable script, and a remote debugging log to go with it (http://xdebug.org/docs/all_settings#remote_log)

meglio

2012-06-25 18:13

reporter   ~0002283

But you previously requested dump files:

>> it would be awesome if you could provide some more information. Have a look at https://bugs.php.net/bugs-generating-backtrace-win32.php [^] under "Generating backtrace, without compiler, on Win32".

meglio

2012-06-25 18:14

reporter   ~0002284

Anyhow I'm not sure if this is still the case. We can hold this issue for a while, but the latest issue I was getting with XDebug we just fixed here:

http://bugs.xdebug.org/view.php?id=856

derick

2012-06-27 21:06

administrator   ~0002291

Let me just close it then for now. Feel free to reopen if you can reproduce it later.

Issue History

Date Modified Username Field Change
2012-04-10 18:45 jos.norberg@gmail.com New Issue
2012-04-12 15:37 jos.norberg@gmail.com Note Added: 0002040
2012-04-14 19:46 meglio Note Added: 0002041
2012-04-14 19:47 meglio Note Edited: 0002041 View Revisions
2012-04-14 19:48 meglio Note Edited: 0002041 View Revisions
2012-04-15 15:04 derick Note Added: 0002042
2012-04-16 17:49 coopster Note Added: 0002049
2012-04-16 19:53 meglio Note Added: 0002050
2012-04-17 00:09 coopster Note Added: 0002051
2012-04-17 21:36 nnmatveev Note Added: 0002052
2012-04-17 21:43 nnmatveev Note Added: 0002053
2012-04-22 12:50 derick Note Added: 0002064
2012-04-22 15:30 derick Note Added: 0002071
2012-04-22 15:30 derick Assigned To => derick
2012-04-22 15:30 derick Status new => feedback
2012-04-22 18:28 coopster Note Added: 0002073
2012-04-27 10:02 meglio Note Added: 0002098
2012-04-30 16:47 coopster Note Added: 0002117
2012-05-11 13:53 dylfin Note Added: 0002142
2012-06-25 18:08 derick Note Added: 0002280
2012-06-25 18:13 meglio Note Added: 0002283
2012-06-25 18:14 meglio Note Added: 0002284
2012-06-27 21:06 derick Note Added: 0002291
2012-06-27 21:06 derick Status feedback => resolved
2012-06-27 21:06 derick Resolution open => no change required
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized