View Issue Details

IDProjectCategoryView StatusLast Update
0000818XdebugUsage problems (Wrong Results)public2012-12-18 12:37
ReporterjohanvAssigned Toderick 
PrioritylowSeveritycrashReproducibilityalways
Status closedResolutionfixed 
PlatformLinuxOSDebianOS Version2.6.32-5-amd64
Product Version2.2.0RC2 
Target Version2.2.2Fixed in Version2.2.2 
Summary0000818: Require a php script in the PHP_RINIT causes Xdebug to crash
DescriptionI've written a small php extension in which a simple script is included in RINIT step. When the Xdebug extension is not enabled, the extension loads and is usable. When Xdebug is enabled, it seems to be triggered on the require command and then crashes.
Steps To ReproduceI've included the source code of my extension - named require - and a script with a function "hello2", to be placed in the include path. Compile and install the extension. With Xdebug disabled, you can do php -m or php -r 'hello2();' which will call the function in the included script.
Enabeling xdebug causes the crash of which the gdb trace is also included.
Additional InformationPHP version is 5.3.9-ZS 5.6.0
TagsNo tags attached.
Operating System
PHP Version5.3.9

Activities

johanv

2012-04-24 10:57

reporter  

XDebug_Crash.zip (2,554 bytes)

johanv

2012-04-25 08:51

reporter   ~0002092

The supplied script and extension are pretty useless, but they are purely to allow an easy reproduction of the problem. It is however impossible to use the SAM extension (Simple Asynchronous Messaging) due to this issue. The SAM extension does the same: it includes a php file in the RINIT.

derick

2012-12-18 12:32

administrator   ~0002398

Fixed for 2.2.2.

Issue History

Date Modified Username Field Change
2012-04-24 10:57 johanv New Issue
2012-04-24 10:57 johanv File Added: XDebug_Crash.zip
2012-04-24 16:30 derick Priority normal => low
2012-04-25 08:51 johanv Note Added: 0002092
2012-04-27 23:54 derick Target Version => 2.2.1
2012-07-14 22:14 derick Target Version 2.2.1 => 2.2.2
2012-12-18 12:32 derick Note Added: 0002398
2012-12-18 12:32 derick Status new => closed
2012-12-18 12:32 derick Assigned To => derick
2012-12-18 12:32 derick Resolution open => fixed
2012-12-18 12:37 derick Fixed in Version => 2.2.2
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)