MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000831XdebugUsage problems (Wrong Results)public2012-05-11 07:492012-05-28 13:05
Reporterrulatir 
Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
StatusclosedResolutionfixed 
PlatformPHP 5.4.3, Apache 2.2.22OSLinuxOS Version3.3.5
Product Version2.2.0 
Target Version2.2.1Fixed in Version2.2.1 
Summary0000831: Debugging terminates in Eclipse when viewing variables (0000797, contd)
DescriptionI am still experiencing the symptom detailed in bug 0000797, which was apparently prematurely closed as fixed.
Steps To ReproduceSet a breakpoint
Run script, XDebug stops at the breakpoint
Select 'Variables' tab in Eclipse (or similar in other IDEs?)
'Unexpected termination of script, debugging ended.'
Additional InformationNOTE WELL ABOUT THE PHP VERSION!!! It's 5.4.3, not 5.4.2. There was no 5.4.3 option in the PHP Version select - please update the options!
TagsNo tags attached.
Operating SystemLinux
PHP Version5.4.2
Attached Files? file icon sample.php [^] (358 bytes) 2012-05-28 01:13

- Relationships

-  Notes
(0002141)
rulatir (reporter)
2012-05-11 07:51

The reporter of issue 830 beat me to it! I swear it didn't show in search results...
(0002148)
derick (administrator)
2012-05-13 22:50

Hi,

In order to reproduce and fix this, I'd need the following information:

- A *short* and *self-contained* script that reproduces the issue while debugging
- A debugging log, which you can make with setting xdebug.remote_log=/tmp/xdebug.log


cheers,
Derick
(0002151)
rulatir (reporter)
2012-05-15 00:22

Consider this a duplicate of 830.
(0002152)
derick (administrator)
2012-05-15 10:41

I know it's a duplicate, but as long as the author in 0000830 doesn't provide useful information, your help would matter greatly!
(0002204)
derick (administrator)
2012-05-28 09:27

I think I've just pushed a fix to github for this issue. Could you please try it?
(0002206)
rulatir (reporter)
2012-05-28 10:23
edited on: 2012-05-28 10:23

Appears to work now! My minimal testcase above - no crash, and speller's testcase with original openid.php works too. I will now stress-test it on my wordpress plugin, but I am optimistic. Thanks!

Did you manage to reproduce it after all? What was the cause (if not too involved to explain)? Will you release a hotfix if others confirm it's fixed?

(0002209)
derick (administrator)
2012-05-28 13:05

I couldn't reproduce it for your specific case still. But it had to do by not checking whether every property was static when trying to read it.

- Issue History
Date Modified Username Field Change
2012-05-11 07:49 rulatir New Issue
2012-05-11 07:51 rulatir Note Added: 0002141
2012-05-13 22:50 derick Note Added: 0002148
2012-05-13 22:50 derick Assigned To => derick
2012-05-13 22:50 derick Status new => feedback
2012-05-15 00:22 rulatir Note Added: 0002151
2012-05-15 00:22 rulatir Status feedback => assigned
2012-05-15 10:41 derick Note Added: 0002152
2012-05-15 10:41 derick Status assigned => feedback
2012-05-15 23:30 derick Target Version => 2.2.1
2012-05-28 01:13 rulatir File Added: sample.php
2012-05-28 09:27 derick Note Added: 0002204
2012-05-28 10:23 rulatir Note Added: 0002206
2012-05-28 10:23 rulatir Status feedback => assigned
2012-05-28 10:23 rulatir Note Edited: 0002206 View Revisions
2012-05-28 13:05 derick Note Added: 0002209
2012-05-28 13:05 derick Status assigned => closed
2012-05-28 13:05 derick Resolution open => fixed
2012-05-28 13:05 derick Fixed in Version => 2.2.1
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker