View Issue Details

IDProjectCategoryView StatusLast Update
0000833XdebugUsage problems (Wrong Results)public2016-11-27 18:27
ReportermotAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformLinuxOSOS Version
Product Version2.2.0 
Target VersionFixed in Version 
Summary0000833: Documentation about segmentation fault with pear upgrade.
DescriptionIf things happen like reported in 0000364 "When I try upgrade all, xdebug can not be upgraded from 2.0.2 to 2.0.3: it crash with segmentation fail after 'xdebug.so' is compiled." (which is unresolved) the following helps to remove the issue:

Move xdebug.so from the php library path as root. It might still be in memory and can not replaced. After moving the file (e.g. xdebug.so -> xdebug2.so), the pear upgrade command works well.

Additional InformationPlease merge this possible solution into the previous ticket.
TagsNo tags attached.
Operating SystemFedora 16
PHP Version5.3.11

Activities

robertbasic

2013-02-10 16:54

reporter   ~0002426

I have ran into the same issue.

pear wanted to upgrade xdebug from version 2.2.0 to 2.2.1 even though php -i already reported xdebug as 2.2.1

It was failing with a segmentation fault.

I simply commented out the xdebug.so call in xdebug.ini, restarted httpd, ran pear upgrade-all, added xdebug.so call back to xdebug.ini, restarted httpd and everything works fine.

Fedora 17 with php 5.4.11 if that matters at all.

derick

2016-11-27 18:27

administrator   ~0003794

I have never been able to reproduce this, and I've not heard about this in a long time. Hence I'm closing this issue.

Issue History

Date Modified Username Field Change
2012-05-12 13:22 mot New Issue
2013-02-10 16:54 robertbasic Note Added: 0002426
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-27 18:27 derick Note Added: 0003794
2016-11-27 18:27 derick Status new => resolved
2016-11-27 18:27 derick Resolution open => unable to reproduce
2016-11-27 18:27 derick Assigned To => derick