View Issue Details

IDProjectCategoryView StatusLast Update
0000084XdebugUsage problems (Wrong Results)public2004-08-16 10:46
Reporterml17Assigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status closedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000084: xdebug does not stop on breakpoints
Descriptionxdebug does not stop on breakpoints
Additional Informationsample protocol from withn weaverslave:
This is Xdebug version 1.3.1dev.
Copyright 2002 by Derick Rethans, JDI Media Solutions.
>option response_format 1
>break sql_select
>break C|/inet/ApacheRoot/Test2/start4.php:18
>run
?init c:\inet\apacheroot\test2\start4.php
+OK
?init c:\inet\apacheroot\test2\start4.php
<xdebug><data><code>1</code><message>Breakpoint set on function.</message></data></xdebug>
+OK
?init c:\inet\apacheroot\test2\start4.php
<xdebug><data><code>1</code><message>Breakpoint set on file:line combination.</message></data></xdebug>
+OK
?init c:\inet\apacheroot\test2\start4.php
<xdebug><run><program>c:\inet\apacheroot\test2\start4.php</program></run></xdebug>
+OK
TagsNo tags attached.
Operating SystemWin XP
PHP Version4.3.8-dev

Activities

derick

2004-08-03 10:24

administrator   ~0000165

Please upgrade to the latest version (1.3.2) first.

ml17

2004-08-04 08:16

reporter   ~0000170

Version 1.3.2 ist not available as a windows binary, at least I can't find it.
I did a complete reinstallation with Apache/2.0.46 und php-4.3.2.
Now debugging works as desired.

derick

2004-08-05 12:13

administrator   ~0000175

closing then

derick

2004-08-16 10:46

administrator   ~0000180

Confirmed by Thomas as working in 1.3.2.

Issue History

Date Modified Username Field Change
2004-08-03 10:21 ml17 New Issue
2004-08-03 10:24 derick Note Added: 0000165
2004-08-03 10:24 derick Status new => feedback
2004-08-04 08:16 ml17 Note Added: 0000170
2004-08-05 12:13 derick Status feedback => resolved
2004-08-05 12:13 derick Resolution open => unable to reproduce
2004-08-05 12:13 derick Assigned To => derick
2004-08-05 12:13 derick Note Added: 0000175
2004-08-16 10:46 derick Status resolved => closed
2004-08-16 10:46 derick Note Added: 0000180
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)