MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000087XdebugUsage problems (Wrong Results)public2004-08-11 09:252006-03-09 14:06
Reporteremgie 
Assigned Toderick 
PrioritynormalSeverityminorReproducibilityunable to reproduce
StatusclosedResolutionreopened 
PlatformOSOS Version
Product Version 
Target VersionFixed in Version 
Summary0000087: Warning about headers when "register_shutdown_function" used
DescriptionWhen "register_shutdown_function" is used in the code, the following warning is issued:
--
Warning: Cannot modify header information - headers already sent in Unknown on line 0
--
All goes well when xdebug.so is not used.
This bug causes PEAR packages to have problems
Additional InformationPHP version is 5.0.0 stable, not -dev (can't choose such an option)

Sample code:

<?php

  function logit($x)
  {
    $f = fopen("/tmp/logit.txt", "a");
    fwrite($f, "$x\n");
    fclose($f);
  }

  function sayonara()
  {
  }

  register_shutdown_function("sayonara");

?>

TagsNo tags attached.
Operating SystemFedora Core 1
PHP Version4.3.0
Attached Files

- Relationships

-  Notes
(0000182)
derick (administrator)
2004-08-23 09:15

I can not reproduce this with your code, it works fine. Can you please give me a list of all xdebug related settings that show up in phpinfo() output?
(0000184)
emgie (reporter)
2004-08-23 13:52

xdebug

xdebug support => enabled
Version => 2.0.0dev

Supported protocols => Revision
DBGp - Common DeBuGger Protocol => $Revision: 1.55 $
GDB - GNU Debugger protocol => $Revision: 1.76 $
PHP3 - PHP 3 Debugger protocol => $Revision: 1.19 $

Directive => Local Value => Master Value
xdebug.allowed_clients => no value => no value
xdebug.auto_trace => Off => Off
xdebug.collect_includes => On => On
xdebug.collect_params => Off => Off
xdebug.collect_return => Off => Off
xdebug.default_enable => On => On
xdebug.dump.COOKIE => no value => no value
xdebug.dump.ENV => no value => no value
xdebug.dump.FILES => no value => no value
xdebug.dump.GET => no value => no value
xdebug.dump.POST => no value => no value
xdebug.dump.REQUEST => no value => no value
xdebug.dump.SERVER => no value => no value
xdebug.dump.SESSION => no value => no value
xdebug.dump_globals => On => On
xdebug.dump_once => On => On
xdebug.dump_undefined => Off => Off
xdebug.extended_info => On => On
xdebug.idekey => maciek => whatever
xdebug.manual_url => http://www.php.net [^] => http://www.php.net [^]
xdebug.max_nesting_level => 100 => 100
xdebug.profiler_enable => Off => Off
xdebug.profiler_output_dir => /tmp => /tmp
xdebug.profiler_output_name => crc32 => crc32
xdebug.remote_enable => On => On
xdebug.remote_handler => gdb => gdb
xdebug.remote_host => localhost => localhost
xdebug.remote_mode => req => req
xdebug.remote_port => 9000 => 9000
xdebug.show_local_vars => Off => Off
xdebug.show_mem_delta => Off => Off
xdebug.trace_format => 0 => 0
xdebug.trace_options => 0 => 0
xdebug.trace_output_dir => /tmp => /tmp
xdebug.trace_output_name => crc32 => crc32


Environment
XDEBUG_CONFIG => remote_handler=gdb
(0000248)
derick (administrator)
2005-03-10 22:42

Is this still a problem with the latest CVS version of Xdebug?
(0000250)
emgie (reporter)
2005-03-17 16:22

Today I've tried the latest Xdebug version and I can reproduce the error, however only using php command line program. PHP module for apache seems to work well. Tried with PHP 5.0 and 4.3.3.
I will be trying to reproduce this at home, on Mandrake Linux 9.1.
(0000340)
derick (administrator)
2006-01-17 21:30

I can still not reproduce this, so I'm marking this bug as "unable to duplicate". If you can provide more information, please reopen.
(0000371)
derick (administrator)
2006-02-21 22:34

I did see this error when running Xdebug with Komodo, so it seems to be valid. Will need to dig into this though.
(0000373)
emgie (reporter)
2006-02-22 09:55

I can confirm the bug's existence on the Fedora Core 4 with updates: PHP version 5.0.4, xdebug 2.0.0rc1-dev, Apache/2.0.54 (Fedora).
The same code used to reproduce the bug.
(0000382)
derick (administrator)
2006-03-09 14:06

Fixed in CVS! (finally :) )

- Issue History
Date Modified Username Field Change
2004-08-11 09:25 emgie New Issue
2004-08-23 09:15 derick Note Added: 0000182
2004-08-23 13:52 emgie Note Added: 0000184
2005-03-10 22:42 derick PHP Version 5.0.0-dev => 4.3.0
2005-03-10 22:42 derick Note Added: 0000248
2005-03-10 22:42 derick Reproducibility always => unable to reproduce
2005-03-10 22:42 derick Status new => feedback
2005-03-17 16:22 emgie Note Added: 0000250
2006-01-17 21:30 derick Status feedback => resolved
2006-01-17 21:30 derick Resolution open => unable to reproduce
2006-01-17 21:30 derick Assigned To => derick
2006-01-17 21:30 derick Note Added: 0000340
2006-02-21 22:34 derick Status resolved => feedback
2006-02-21 22:34 derick Resolution unable to reproduce => reopened
2006-02-21 22:34 derick Note Added: 0000371
2006-02-22 09:55 emgie Note Added: 0000373
2006-03-09 14:06 derick Status feedback => closed
2006-03-09 14:06 derick Note Added: 0000382
2016-07-31 13:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 13:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker