View Issue Details

IDProjectCategoryView StatusLast Update
0000873XdebugUsage problems (Wrong Results)public2016-12-03 23:59
ReporterrobertjohnsonAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformWindowsOSXP SP3OS Version5.1 SP3
Product Version2.2.1 
Target VersionFixed in Version2.2.4 
Summary0000873: Crash viewing COM object properties in Eclipse PDT
DescriptionIn Eclipse PDT, PHP crashes when a COM object is in scope.

Crash does not occur when Variables/Expressions is hidden, but still occurs when hovering over the COM object.

Whenever Eclipse tries to evaluate the object or expression in the debugger, PHP crashes.
Steps To ReproduceOn Windows, run a php script containing this, and step to the 2nd statement.

<?php
$conn = new COM('ADODB.Connection', NULL, CP_UTF8);

/* To crash PHP:
 * Hover over $conn->State
 * Open 'Variables' pane
 * Open 'Expressions' pane and watch $conn - value
 * shows as (Pending) then PHP crashes (attached png)
 * */

$state = $conn->State;
?>
Additional InformationEclipse Juno Classic with installed PDT
PHP 5.4.5
Apache web server 2.2 + FCGID interface for PHP.
TagsNo tags attached.
Operating SystemWin XP SP3
PHP Version5.5.5-5.5.9

Relationships

duplicate of 0000976 closedderick XDebug crashes if current varibles scope contains COM object 

Activities

robertjohnson

2012-08-20 11:25

reporter  

xdebug.png (75,230 bytes)
xdebug.png (75,230 bytes)

robertjohnson

2012-10-11 10:13

reporter   ~0002358

I have fixed this myself for now, by editing the com_dotnet extension, although the bug is in xdebug, and not com_dotnet.

zend_object_handlers.get_properties returns NULL in com_dotnet, which causes xdebug to crash.

Proof that this is a bug in xdebug:

<?php
$conn = new COM('ADODB.Connection', NULL, CP_UTF8);
var_dump($conn);
?>

Result without xdebug:
object(com)#1 (0) { }

Result with xdebug:
Internal Server Error/system exception (xdebug crashes PHP)

derick

2014-02-27 19:41

administrator   ~0002707

Duplicate of 0000976, which is fixed for 2.2.4/2.3.0.

robertjohnson

2014-06-09 11:45

reporter   ~0002844

Script:
<?php
$conn = new COM('ADODB.Connection', NULL, CP_UTF8);
var_dump($conn);
?>

Outputs:
object(com)#1 (0) { }

When xdebug is loaded, PHP crashes. Unfortunately the issue has not been fixed in xdebug 2.2.5 on PHP 5.5 NTS VC11

derick

2016-11-28 21:30

administrator   ~0003831

Is this still a problem for you?

derick

2016-12-03 23:59

administrator   ~0003890

The email bounced, so closing this.

Issue History

Date Modified Username Field Change
2012-08-20 11:25 robertjohnson New Issue
2012-08-20 11:25 robertjohnson File Added: xdebug.png
2012-10-11 10:13 robertjohnson Note Added: 0002358
2014-02-27 19:41 derick Note Added: 0002707
2014-02-27 19:41 derick Relationship added duplicate of 0000976
2014-02-27 19:41 derick Status new => resolved
2014-02-27 19:41 derick Fixed in Version => 2.2.4
2014-02-27 19:41 derick Resolution open => duplicate
2014-02-27 19:41 derick Assigned To => derick
2014-06-09 11:45 robertjohnson PHP Version 5.4.4 => 5.5.5-5.5.9
2014-06-09 11:45 robertjohnson Note Added: 0002844
2014-06-09 11:45 robertjohnson Status resolved => feedback
2014-06-09 11:45 robertjohnson Resolution duplicate => reopened
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2016-11-28 21:30 derick Note Added: 0003831
2016-11-28 21:30 derick Status feedback => new
2016-11-28 21:30 derick Status new => feedback
2016-12-03 23:59 derick Note Added: 0003890
2016-12-03 23:59 derick Status feedback => resolved
2016-12-03 23:59 derick Resolution reopened => unable to reproduce