MantisBT

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0000883Xdebug(No Category)public2012-09-20 14:322013-05-22 04:51
Reporterakapuya 
Assigned Toderick 
PriorityhighSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
PlatformintelOSWindowsOS Version7 64bit
Product Version2.2.1 
Target Version2.2.3Fixed in Version2.2.3 
Summary0000883: Debugging PHP with MongoDB using Cursor, causes debug session termination and exception
DescriptionWhen using MongoDB extension, every time a cursor is used to query data from DB, debugger crashes (tried both Netbeans and Eclipse, same results)
Steps To Reproduceany program using MongoCursor
Additional Informationjava.net.SocketException: Connection reset
    at java.net.SocketInputStream.read(SocketInputStream.java:189)
    at java.net.SocketInputStream.read(SocketInputStream.java:121)
    at java.net.SocketInputStream.read(SocketInputStream.java:203)
    at org.netbeans.modules.php.dbgp.packets.DbgpMessage.getDataSize(DbgpMessage.java:297)
    at org.netbeans.modules.php.dbgp.packets.DbgpMessage.create(DbgpMessage.java:126)
    at org.netbeans.modules.php.dbgp.DebugSession.receiveData(DebugSession.java:265)
    at org.netbeans.modules.php.dbgp.DebugSession.sendCommands(DebugSession.java:213)
[catch] at org.netbeans.modules.php.dbgp.DebugSession.run(DebugSession.java:143)
    at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:471)
    at java.util.concurrent.FutureTask$Sync.innerRun(FutureTask.java:334)
    at java.util.concurrent.FutureTask.run(FutureTask.java:166)
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
    at java.lang.Thread.run(Thread.java:722)
TagsNo tags attached.
Operating SystemWindows
PHP Version5.4-dev
Attached Files

- Relationships

-  Notes
(0002349)
derick (administrator)
2012-10-01 13:01

I tried to reproduce this, but I did not manage. Can you provide:

1. a short and self contained script that demonstrates the problem
2. a remote log to go with this. See http://xdebug.org/docs/all_settings#remote_log [^] on how to do that.
(0002366)
derick (administrator)
2012-10-21 20:10

Hello? Could you please provide the requested information?
(0002379)
derick (administrator)
2012-11-11 12:59

Couldn't reproduce, and no feedback provided.
(0002462)
derick (administrator)
2013-05-14 19:12

This was a bug after all, as a duplicate of 0000923.

- Issue History
Date Modified Username Field Change
2012-09-20 14:32 akapuya New Issue
2012-10-01 13:01 derick Note Added: 0002349
2012-10-01 13:01 derick Assigned To => derick
2012-10-01 13:01 derick Status new => feedback
2012-10-21 20:10 derick Note Added: 0002366
2012-11-11 12:59 derick Note Added: 0002379
2012-11-11 12:59 derick Status feedback => resolved
2012-11-11 12:59 derick Resolution open => unable to reproduce
2013-05-14 19:12 derick Note Added: 0002462
2013-05-14 19:12 derick Status resolved => closed
2013-05-14 19:12 derick Fixed in Version => 2.2.3
2013-05-22 04:51 derick Target Version => 2.2.3
2016-07-31 13:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 13:35 derick Category debugclient (debugging tool) => (No Category)


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker