View Issue Details

IDProjectCategoryView StatusLast Update
0000891XdebugInstallationpublic2012-10-12 09:39
ReporterseanrAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionno change required 
PlatformMacOSOSXOS Version10.7.5
Product Version2.2.1 
Target VersionFixed in Version 
Summary0000891: image not found error when attempting to load xdebug
DescriptionFollowed the wizard's instructions successfully, but I am not able to get xdebug to load at all. I get the following error:

Failed loading ”/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so”: dlopen(”/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so”, 9): image not found

This is in my php.ini:

zend_extension=”/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so”
xdebug.file_link_format="txmt://open?url=file://%f&line=%1"
xdebug.remote_enable = On
xdebug.remote_autostart = 1

I've confirmed that file is indeed there:

$ ls -al /Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so
-rwxr-xr-x 1 root admin 223944 Oct 4 16:56 /Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so
Steps To ReproduceDownload xdebug-2.2.1.tgz
Unpack the downloaded file with tar -xvzf xdebug-2.2.1.tgz
Run: cd xdebug-2.2.1
Run: phpize
Run: ./configure
Run: make
Run: cp modules/xdebug.so /Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626
Edit /Applications/XAMPP/xamppfiles/etc/php.ini and add the line
zend_extension = /Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so
Restart the webserver
Additional InformationI've also tried the version packaged with XAMPP and no luck there either.
TagsNo tags attached.
Operating SystemOSX 10.7.5
PHP Version5.3.1

Activities

derick

2012-10-06 11:23

administrator   ~0002356

zend_extension=”/Applications/XAMPP/xamppfiles/lib/php/php-5.3.1/extensions/no-debug-non-zts-20090626/xdebug.so”

That looks like curly quotes, and not straight quotes. Could that be it? Note that the output doesn't show quotes at all.

seanr

2012-10-08 15:30

reporter   ~0002357

That is indeed what it was. God, who the hell invented curly quotes?

Thanks.

derick

2012-10-12 09:39

administrator   ~0002361

No worries :-) Closing this then.

Issue History

Date Modified Username Field Change
2012-10-04 21:15 seanr New Issue
2012-10-06 11:23 derick Note Added: 0002356
2012-10-06 11:23 derick Assigned To => derick
2012-10-06 11:23 derick Status new => feedback
2012-10-08 15:30 seanr Note Added: 0002357
2012-10-08 15:30 seanr Status feedback => assigned
2012-10-12 09:39 derick Note Added: 0002361
2012-10-12 09:39 derick Status assigned => resolved
2012-10-12 09:39 derick Resolution open => no change required