View Issue Details

IDProjectCategoryView StatusLast Update
0000904XdebugInstallationpublic2014-03-12 21:53
ReporterlucassrodAssigned Toderick 
PrioritylowSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformlinuxOSSabayon Linux OS Version10
Product Version2.2.1 
Target VersionFixed in Version 
Summary0000904: Cannot run make
Description~/Downloads/xdebug-2.2.1 $ make
/bin/sh /home/lucas/Downloads/xdebug-2.2.1/libtool --mode=compile cc -I. -I/home/lucas/Downloads/xdebug-2.2.1 -DPHP_ATOM_INC -I/home/lucas/Downloads/xdebug-2.2.1/include -I/home/lucas/Downloads/xdebug-2.2.1/main -I/home/lucas/Downloads/xdebug-2.2.1 -I/usr/lib64/php5.4/include/php -I/usr/lib64/php5.4/include/php/main -I/usr/lib64/php5.4/include/php/TSRM -I/usr/lib64/php5.4/include/php/Zend -I/usr/lib64/php5.4/include/php/ext -I/usr/lib64/php5.4/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/lucas/Downloads/xdebug-2.2.1/xdebug.c -o xdebug.lo
/home/lucas/Downloads/xdebug-2.2.1/libtool: line 481: CDPATH: command not found
libtool: Version mismatch error. This is libtool 2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4
libtool: and run autoconf again.
make: *** [xdebug.lo] Error 63
Steps To Reproduce~/Downloads/xdebug-2.2.1 $ phpize
Configuring for:
PHP Api Version: 20100412
Zend Module Api No: 20100525
Zend Extension Api No: 220100525


~/Downloads/xdebug-2.2.1 $ ./configure --enable-xdebug
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for a sed that does not truncate output... /bin/sed
checking for cc... cc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ISO C89... none needed
checking how to run the C preprocessor... cc -E
checking for icc... no
checking for suncc... no
checking whether cc understands -c and -o together... yes
checking for system library directory... lib
checking if compiler supports -R... no
checking if compiler supports -Wl,-rpath,... yes
checking build system type... x86_64-unknown-linux-gnu
checking host system type... x86_64-unknown-linux-gnu
checking target system type... x86_64-unknown-linux-gnu
checking for PHP prefix... /usr/lib64/php5.4
checking for PHP includes... -I/usr/lib64/php5.4/include/php -I/usr/lib64/php5.4/include/php/main -I/usr/lib64/php5.4/include/php/TSRM -I/usr/lib64/php5.4/include/php/Zend -I/usr/lib64/php5.4/include/php/ext -I/usr/lib64/php5.4/include/php/ext/date/lib
checking for PHP extension directory... /usr/lib64/php5.4/lib/extensions/no-debug-non-zts-20100525
checking for PHP installed headers prefix... /usr/lib64/php5.4/include/php
checking if debug is enabled... no
checking if zts is enabled... no
checking for re2c... no
configure: WARNING: You will need re2c 0.13.4 or later if you want to regenerate PHP parsers.
checking for gawk... gawk
checking whether to enable eXtended debugging support... yes, shared
checking Check for supported PHP versions... supported (5.4.7--pl0-gentoo)
checking for gettimeofday... yes
checking for cos in -lm... yes
checking for ld used by cc... /usr/x86_64-pc-linux-gnu/bin/ld
checking if the linker (/usr/x86_64-pc-linux-gnu/bin/ld) is GNU ld... yes
checking for /usr/x86_64-pc-linux-gnu/bin/ld option to reload object files... -r
checking for BSD-compatible nm... /usr/bin/nm -B
checking whether ln -s works... yes
checking how to recognize dependent libraries... pass_all
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking dlfcn.h usability... yes
checking dlfcn.h presence... yes
checking for dlfcn.h... yes
checking the maximum length of command line arguments... 1572864
checking command to parse /usr/bin/nm -B output from cc object... ok
checking for objdir... .libs
checking for ar... ar
checking for ranlib... ranlib
checking for strip... strip
checking if cc supports -fno-rtti -fno-exceptions... no
checking for cc option to produce PIC... -fPIC
checking if cc PIC flag -fPIC works... yes
checking if cc static flag -static works... yes
checking if cc supports -c -o file.o... yes
checking whether the cc linker (/usr/x86_64-pc-linux-gnu/bin/ld -m elf_x86_64) supports shared libraries... yes
checking whether -lc should be explicitly linked in... no
checking dynamic linker characteristics... GNU/Linux ld.so
checking how to hardcode library paths into programs... immediate
checking whether stripping libraries is possible... yes
checking if libtool supports shared libraries... yes
checking whether to build shared libraries... yes
checking whether to build static libraries... no

creating libtool
appending configuration tag "CXX" to libtool
configure: creating ./config.status
config.status: creating config.h
config.status: config.h is unchanged


 ~/Downloads/xdebug-2.2.1 $ make
/bin/sh /home/lucas/Downloads/xdebug-2.2.1/libtool --mode=compile cc -I. -I/home/lucas/Downloads/xdebug-2.2.1 -DPHP_ATOM_INC -I/home/lucas/Downloads/xdebug-2.2.1/include -I/home/lucas/Downloads/xdebug-2.2.1/main -I/home/lucas/Downloads/xdebug-2.2.1 -I/usr/lib64/php5.4/include/php -I/usr/lib64/php5.4/include/php/main -I/usr/lib64/php5.4/include/php/TSRM -I/usr/lib64/php5.4/include/php/Zend -I/usr/lib64/php5.4/include/php/ext -I/usr/lib64/php5.4/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/lucas/Downloads/xdebug-2.2.1/xdebug.c -o xdebug.lo
/home/lucas/Downloads/xdebug-2.2.1/libtool: line 481: CDPATH: command not found
libtool: Version mismatch error. This is libtool 2.4, but the
libtool: definition of this LT_INIT comes from an older release.
libtool: You should recreate aclocal.m4 with macros from libtool 2.4
libtool: and run autoconf again.
make: *** [xdebug.lo] Error 63

Additional InformationFollow this wizard:

Summary

Xdebug installed: no
Server API: Apache 2.0 Handler
Windows: no
Zend Server: no
PHP Version: 5.4.7--
Zend API nr: 220100525
PHP API nr: 20100525
Debug Build: no
Thread Safe Build: no
Configuration File Path: /etc/php/apache2-php5.4
Configuration File: /etc/php/apache2-php5.4/php.ini
Extensions directory: /usr/lib64/php5.4/lib/extensions/no-debug-non-zts-20100525
Instructions

Download xdebug-2.2.1.tgz
Unpack the downloaded file with tar -xvzf xdebug-2.2.1.tgz
Run: cd xdebug-2.2.1
Run: phpize

As part of its output it should show:

Configuring for:
...
Zend Module Api No: 20100525
Zend Extension Api No: 220100525
If it does not, you are using the wrong phpize. Please follow this FAQ entry and skip the next step.

Run: ./configure
Run: make
Run: cp modules/xdebug.so /usr/lib64/php5.4/lib/extensions/no-debug-non-zts-20100525
Edit /etc/php/apache2-php5.4/php.ini and add the line
zend_extension = /usr/lib64/php5.4/lib/extensions/no-debug-non-zts-20100525/xdebug.so
Restart the webserver
TagsNo tags attached.
Operating SystemLinux
PHP Version5.4.4

Activities

derick

2012-11-24 17:29

administrator   ~0002385

Not quite sure what to do about this one. This obviously works fine for me. Did you use your distribution's package for PHP itself?

derick

2012-12-17 20:58

administrator   ~0002395

Hi,

I can not reproduce this myself, so could you please provide what you are compiling against here? I have never even heard of Sabayon Linux.

cheers,
Derick

lucassrod

2012-12-18 12:20

reporter   ~0002397

I will describe it, when arrive in home.

Sabayon linux it is a distro based on Gentoo Linux. This distro it is awesome and there are not complications to install. Its easy and fast, really fast.

http://www.sabayon.org/

derick

2014-02-27 19:43

administrator   ~0002710

Can you please provide the feedback? For example whether this is still an issue?

derick

2014-03-12 21:53

administrator   ~0002769

Closing this out as I can't reproduce it and no feedback was provided. Please re-open if this issue returns.

Issue History

Date Modified Username Field Change
2012-11-24 16:53 lucassrod New Issue
2012-11-24 17:29 derick Note Added: 0002385
2012-11-24 17:29 derick Assigned To => derick
2012-11-24 17:29 derick Status new => feedback
2012-12-17 20:58 derick Note Added: 0002395
2012-12-18 12:20 lucassrod Note Added: 0002397
2012-12-18 12:20 lucassrod Status feedback => assigned
2014-02-27 19:43 derick Note Added: 0002710
2014-02-27 19:43 derick Status assigned => feedback
2014-03-12 21:53 derick Note Added: 0002769
2014-03-12 21:53 derick Status feedback => resolved
2014-03-12 21:53 derick Resolution open => no change required