View Issue Details

IDProjectCategoryView StatusLast Update
0000907XdebugInstallationpublic2014-03-12 21:53
Reporterpeter.kehlAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityhave not tried
Status resolvedResolutionno change required 
PlatformPHP 5.5 alpha1OSLinuxOS VersionCentOS 6.2 x64
Product Version 
Target VersionFixed in Version 
Summary0000907: Can't compile XDebug from GIT withj PHP 5.5
DescriptionI know that XDebug 2.2.1 won't work with PHP 5.5. But seeing http://bugs.xdebug.org/view.php?id=905 made me think that you have a branch/revision which would work with PHP 5.5.

So I've got the current git master of XDebug, compiled it with PHP 5.5 alpha1, and it won't compile. The error is different to one that you get when you try to compile 2.2.1 with same PHP alpha1.
Steps To Reproduce
cat .git/HEAD
ref: refs/heads/master
[pkehl@pkehlcentos xdebug]$ cat .git/refs/heads/master
9b619908433247fc2316f3c28c3e73d87f1c2050

cd xdebug
/usr/local/php/bin/phpize
./configure --enable-xdebug --with-php-config=/usr/local/php/bin/php-config
make
/bin/sh /home/pkehl/xdebug/libtool --mode=compile cc -I. -I/home/pkehl/xdebug -DPHP_ATOM_INC -I/home/pkehl/xdebug/include -I/home/pkehl/xdebug/main -I/home/pkehl/xdebug -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/pkehl/xdebug/xdebug.c -o xdebug.lo
mkdir .libs
 cc -I. -I/home/pkehl/xdebug -DPHP_ATOM_INC -I/home/pkehl/xdebug/include -I/home/pkehl/xdebug/main -I/home/pkehl/xdebug -I/usr/local/php/include/php -I/usr/local/php/include/php/main -I/usr/local/php/include/php/TSRM -I/usr/local/php/include/php/Zend -I/usr/local/php/include/php/ext -I/usr/local/php/include/php/ext/date/lib -DHAVE_CONFIG_H -g -O2 -c /home/pkehl/xdebug/xdebug.c -fPIC -DPIC -o .libs/xdebug.o
/home/pkehl/xdebug/xdebug.c: In function ‘zm_startup_xdebug’:
/home/pkehl/xdebug/xdebug.c:576: error: ‘zend_execute_ex’ undeclared (first use in this function)
/home/pkehl/xdebug/xdebug.c:576: error: (Each undeclared identifier is reported only once
/home/pkehl/xdebug/xdebug.c:576: error: for each function it appears in.)
/home/pkehl/xdebug/xdebug.c: In function ‘zm_shutdown_xdebug’:
/home/pkehl/xdebug/xdebug.c:719: error: ‘zend_execute_ex’ undeclared (first use in this function)
Additional InformationIf it helps, I compiled PHP 5.5 alpha 1 using:

./configure --prefix=/usr/local/php --with-apxs2=/usr/sbin/apxs --enable-mbstring --with-curl --with-openssl --with-xmlrpc --enable-soap --enable-zip --with-gd --with-jpeg-dir --with-png-dir --with-mysql --with-pgsql --enable-embedded-mysqli --with-freetype-dir --with-ldap --enable-intl --with-mssql --with-zlib
make
sudo make install

phpinfo says:
PHP API 20121113
PHP Extension 20121113
Zend Extension 220121113
Zend Extension Build API220121113,NTS
PHP Extension Build API20121113,NTS

Apache/2.2.15 (CentOS)
Apache API Version 20051115

I'm happy to recompile or run some commands if you tell me what.
TagsNo tags attached.
Operating SystemCentOS 6.2 x64
PHP Version5.5-dev

Activities

peter.kehl

2012-12-05 06:47

reporter   ~0002387

phpize shows:
Configuring for:
PHP Api Version: 20121113
Zend Module Api No: 20121113
Zend Extension Api No: 220121113

Also, I've run 'git checkout xdebug_2_2', but I still get same compile error.

derick

2014-02-27 19:42

administrator   ~0002709

This should just work fine now, is this still a problem?

derick

2014-03-12 21:53

administrator   ~0002768

Closing this out as I can't reproduce it and no feedback was provided. Please re-open if this issue returns.

Issue History

Date Modified Username Field Change
2012-12-05 06:40 peter.kehl New Issue
2012-12-05 06:47 peter.kehl Note Added: 0002387
2014-02-27 19:42 derick Note Added: 0002709
2014-02-27 19:42 derick Assigned To => derick
2014-02-27 19:42 derick Status new => feedback
2014-03-12 21:53 derick Note Added: 0002768
2014-03-12 21:53 derick Status feedback => resolved
2014-03-12 21:53 derick Resolution open => no change required