View Issue Details

IDProjectCategoryView StatusLast Update
0000908XdebugFeature/Change requestpublic2016-12-11 13:00
ReporterwhitefireAssigned Toderick 
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionduplicate 
PlatformN/AOSN/AOS VersionN/A
Product Version 
Target VersionFixed in Version 
Summary0000908: Support for set-execution-point
DescriptionHi!

I previously used Nusphere's IDE when developing PHP. They have their own proprietary debug-module. Though xDebug is superior in most ways, there is a feature that I miss.

As a user you could right click any line within the current scope and select "set execution point". Unlike "run to line" this was also allowed backwards in code. Very useful when accidentally stepping to far or if you wanted to try something different. It would also allow the user to prevent lines from execution by skipping past them.

I hope you will consider implementing this feature as it allows the user to do some powerful voodoo when debugging.
TagsNo tags attached.
Operating SystemN/A
PHP Version5.3.14

Relationships

duplicate of 0000888 acknowledgedderick Extend xdebug to support reverse debugging 

Activities

derick

2016-12-11 13:00

administrator   ~0003983

This is sort of the same feature as 888, or at least, the implementation would be the same. So I'm closing this as a Duplicate.

Issue History

Date Modified Username Field Change
2012-12-11 10:54 whitefire New Issue
2014-02-27 19:42 derick Relationship added related to 0000888
2016-12-11 13:00 derick Note Added: 0003983
2016-12-11 13:00 derick Relationship replaced duplicate of 0000888
2016-12-11 13:00 derick Status new => resolved
2016-12-11 13:00 derick Resolution open => duplicate
2016-12-11 13:00 derick Assigned To => derick