View Issue Details

IDProjectCategoryView StatusLast Update
0000091XdebugDocumentationpublic2004-09-18 08:54
ReporterspookworkAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Product Version 
Target VersionFixed in Version 
Summary0000091: breakpoint_remove is not behaving as documented
DescriptionDuring execution my IDE issued the command "breakpoint_remove -i TID -d BID" but the response was always a 204 which referred to an improper STATE. In the documentation the STATE option is used with breakpoint_update but is not used with breakpoint_remove. Attempting to remove the association to the breakpoint with "breakpoint_update -i TID -d BID -s disabled" returned an error "3".

The final solution was found by using the following command:
"breakpoint_remove -i TID -d BID -s disabled"
TagsNo tags attached.
Operating SystemWindows
PHP Version4.3.8

Activities

derick

2004-09-18 08:54

administrator   ~0000194

This works fine for me:

<init fileuri="file:///home/derick/test.php" language="PHP" protocol_version="1.0" appid="3099" idekey="xdebul1"><engine version="2.0.0beta1"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2004 by Derick Rethans]]></copyright></init>

(cmd) breakpoint_set -i 1 -f test.php -n 2
<response command="breakpoint_set" transaction_id="1" status="starting" reason="ok"><error code="3"></error></response>

(cmd) breakpoint_set -i 1 -t line -f test.php -n 2
<response command="breakpoint_set" transaction_id="1" id="30990001"></response>

(cmd) breakpoint_remove -i 2 -d 30990001
<response command="breakpoint_remove" transaction_id="2"><breakpoint type="line" filename="file:///home/derick/test.php" lineno="2" state="enabled" id="30990001"></breakpoint></response>

(cmd) breakpoint_list -i 3
<response command="breakpoint_list" transaction_id="3"></response>

(cmd) breakpoint_set -i 4 -t line -f test.php -n 2
<response command="breakpoint_set" transaction_id="4" id="30990002"></response>

(cmd) breakpoint_list -i 5
<response command="breakpoint_list" transaction_id="5"><breakpoint type="line" filename="file:///home/derick/test.php" lineno="2" state="enabled" id="30990002"></breakpoint></response>

(cmd) breakpoint_remove -i 6 -d 30990001
<response command="breakpoint_remove" transaction_id="6" status="starting" reason="ok"><error code="204"></error></response>

(cmd) breakpoint_remove -i 7 -d 30990002
<response command="breakpoint_remove" transaction_id="7" status="starting" reason="ok"><error code="204"></error></response>


There are also no checks in the code that demand the -s option to be set here.

Issue History

Date Modified Username Field Change
2004-09-09 17:02 spookwork New Issue
2004-09-18 08:54 derick Status new => resolved
2004-09-18 08:54 derick Resolution open => unable to reproduce
2004-09-18 08:54 derick Assigned To => derick
2004-09-18 08:54 derick Note Added: 0000194