View Issue Details

IDProjectCategoryView StatusLast Update
0000941XdebugUncategorizedpublic2013-06-15 12:12
Reporterthiagomp Assigned Toderick  
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
OSWindowsOS Version7 
Product Version2.2.2 
Summary0000941: trace_format=1 is being ignored
DescriptionWhen changing the variable trace_format to 1 or 2, Xdebug is not generating the expected file output.
The change can be done in the php.ini or directly from the command line (using php -d xdebug.trace_format=1)

Definitely I'm doing something wrong here, but I'm not being able to identify what is the problem.
Steps To ReproduceIn my case, I have installed the environment using wamp server [1] and after I got this problem, I've manually updated the dll from php_xdebug-2.2.0-5.3-vc9-x86_64.dll to php_xdebug-2.2.2-5.3-vc9-x86_64.dll

[1] http://www.wampserver.com/en/
Additional InformationI've even tried to execute using php -n and passing all the "-d" options that the script needed, but not success on getting the other output version
TagsNo tags attached.
Operating SystemWindows 7
PHP Version5.3.13

Activities

derick

2013-05-14 18:16

administrator   ~0002463

Do you realize the name of the setting is "xdebug.trace_format", and not just "format"? Can you show me the full line that you're trying on the command line, as well as attach "php -i"'s output?

thiagomp

2013-06-14 17:44

reporter   ~0002504

Hello Derick,

thanks for your attention on this.
Today I tried to make it work and I realized that I was missing "xdebug.auto_trace = On" on my php.ini.
Now the file is being created as expected.

I believe we can close this ticket.

derick

2013-06-15 12:12

administrator   ~0002505

Okay, closing this issue then!

Issue History

Date Modified Username Field Change
2013-04-09 15:15 thiagomp New Issue
2013-05-14 18:16 derick Note Added: 0002463
2013-05-14 18:16 derick Assigned To => derick
2013-05-14 18:16 derick Status new => feedback
2013-06-14 17:44 thiagomp Note Added: 0002504
2013-06-14 17:44 thiagomp Status feedback => assigned
2013-06-15 12:12 derick Note Added: 0002505
2013-06-15 12:12 derick Status assigned => resolved
2013-06-15 12:12 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)
2020-03-12 16:35 derick Category Usage problems (Wrong Results) => Variable Display
2020-03-12 16:38 derick Category Variable Display => Uncategorized