View Issue Details

IDProjectCategoryView StatusLast Update
0000943Xdebug(No Category)public2014-03-02 14:20
ReporterzyongAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformphp5.4 OSubuntu OS Version12.04 x86-64
Product Version 
Target VersionFixed in Version 
Summary0000943: It can't debug in eclipse neither on windows or linux(ubuntu)
DescriptionI used eclipse to debug on Windows, It's always right before, but It couldn't be launched sometimes ago. I didn't know why it, I tried to debug on Linux in same way, the results was same as. Maybe it's a bug or not.

here is some informations I used strace get it,

[pid 3776] recvfrom(11, 0x7f0ad8252be4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 3776] poll([{fd=9, events=POLLIN}, {fd=11, events=POLLIN}, {fd=65, events=POLLIN}, {fd=127, events=POLLIN}, {fd=67, events=POLLIN}], 5, 0) = 0 (Timeout)
[pid 3776] read(9, 0x7f0adec22850, 16) = -1 EAGAIN (Resource temporarily unavailable)
[pid 3776] recvfrom(11, 0x7f0ad8252be4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 3776] poll([{fd=9, events=POLLIN}, {fd=11, events=POLLIN}, {fd=65, events=POLLIN}, {fd=127, events=POLLIN}, {fd=67, events=POLLIN}], 5, 0) = 0 (Timeout)
[pid 3776] read(9, 0x7f0adec22850, 16) = -1 EAGAIN (Resource temporarily unavailable)
[pid 3776] recvfrom(11, 0x7f0ad8252be4, 4096, 0, 0, 0) = -1 EAGAIN (Resource temporarily unavailable)
[pid 3776] poll([{fd=9, events=POLLIN}, {fd=11, events=POLLIN}, {fd=65, events=POLLIN}, {fd=127, events=POLLIN}, {fd=67, events=POLLIN}], 5, 100 <unfinished ...>
[pid 3814] <... futex resumed> ) = -1 ETIMEDOUT (Connection timed out)
[pid 3814] futex(0x7f0ad8bc1a28, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 3814] futex(0x7f0ad8bc1a54, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, {1366369058, 226654000}, ffffffff <unfinished ...>
[pid 3786] <... futex resumed> ) = -1 ETIMEDOUT (Connection timed out)
[pid 3786] futex(0x7f0ad817e828, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 3786] futex(0x7f0ad817e854, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, {1366369058, 188919000}, ffffffff) = -1 ETIMEDOUT (Connection timed out)
[pid 3786] futex(0x7f0ad817e828, FUTEX_WAKE_PRIVATE, 1) = 0
[pid 3786] futex(0x7f0ad817e854, FUTEX_WAIT_BITSET_PRIVATE|FUTEX_CLOCK_REALTIME, 1, {1366369058, 239264000}, ffffffff <unfinished ...
TagsNo tags attached.
Operating System
PHP Version5.4.10-5.4.14

Activities

zyong

2013-04-19 11:32

reporter  

remote_log (4,916 bytes)
Log opened at 2013-04-19 11:05:40
I: Connecting to configured address/port: 127.0.0.1:9001.
I: Connected to client. :-)
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/zhaoyong/www/help/public/index.php" language="PHP" protocol_version="1.0" appid="4884" idekey="ECLIPSE_DBGP"><engine version="2.2.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2013 by Derick Rethans]]></copyright></init>

<- feature_set -i 19 -n show_hidden -v 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="19" feature="show_hidden" success="1"></response>

<- feature_set -i 20 -n max_depth -v 3
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="20" feature="max_depth" success="1"></response>

<- feature_set -i 21 -n max_children -v 31
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="21" feature="max_children" success="1"></response>

<- feature_get -i 22 -n encoding
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="22" feature_name="encoding" supported="1"><![CDATA[iso-8859-1]]></response>

<- feature_get -i 23 -n supports_async
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="23" feature_name="supports_async" supported="1"><![CDATA[0]]></response>

<- stdout -i 24 -c 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stdout" transaction_id="24" success="1"></response>

<- stderr -i 25 -c 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stderr" transaction_id="25" success="0"></response>

<- step_into -i 26
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="26" status="stopping" reason="ok"></response>

<- stop -i 27
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stop" transaction_id="27" status="stopped" reason="ok"></response>

Log closed at 2013-04-19 11:05:41

Log opened at 2013-04-19 11:21:43
I: Connecting to configured address/port: 127.0.0.1:9001.
I: Connected to client. :-)
-> <init xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" fileuri="file:///home/zhaoyong/www/help/public/index.php" language="PHP" protocol_version="1.0" appid="4885" idekey="ECLIPSE_DBGP"><engine version="2.2.2"><![CDATA[Xdebug]]></engine><author><![CDATA[Derick Rethans]]></author><url><![CDATA[http://xdebug.org]]></url><copyright><![CDATA[Copyright (c) 2002-2013 by Derick Rethans]]></copyright></init>

<- feature_set -i 28 -n show_hidden -v 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="28" feature="show_hidden" success="1"></response>

<- feature_set -i 29 -n max_depth -v 3
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="29" feature="max_depth" success="1"></response>

<- feature_set -i 30 -n max_children -v 31
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_set" transaction_id="30" feature="max_children" success="1"></response>

<- feature_get -i 31 -n encoding
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="31" feature_name="encoding" supported="1"><![CDATA[iso-8859-1]]></response>

<- feature_get -i 32 -n supports_async
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="feature_get" transaction_id="32" feature_name="supports_async" supported="1"><![CDATA[0]]></response>

<- stdout -i 33 -c 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stdout" transaction_id="33" success="1"></response>

<- stderr -i 34 -c 1
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stderr" transaction_id="34" success="0"></response>

<- step_into -i 35
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="step_into" transaction_id="35" status="stopping" reason="ok"></response>

<- stop -i 36
-> <response xmlns="urn:debugger_protocol_v1" xmlns:xdebug="http://xdebug.org/dbgp/xdebug" command="stop" transaction_id="36" status="stopped" reason="ok"></response>

Log closed at 2013-04-19 11:21:43

remote_log (4,916 bytes)

derick

2013-05-18 21:30

administrator   ~0002473

The debugging seems to start just fine according to the log, what exactly is in /home/zhaoyong/www/help/public/index.php ?

zyong

2013-05-21 13:23

reporter   ~0002478

I use Yii framework, index.php is single entrance for framework. I think I have already solved problem, I found it's a wrong of setting in IDE and I read PDT manual again, Setting of my eclipse was not for xdebug exactly, I modified it and It's all right now.

derick

2014-02-27 19:50

administrator   ~0002716

The log looks fine. I am wondering what your strace is supposed to show,
      as I don't get it.

zyong

2014-02-28 01:47

reporter   ~0002729

You mean the log is not about xdebug?

derick

2014-03-02 14:20

administrator   ~0002734

The strace log that you put in the description is indeed not very useful. But in any case, I think you said before that it is solved now for you, so I am closing this issue. Thanks!

Issue History

Date Modified Username Field Change
2013-04-19 11:32 zyong New Issue
2013-04-19 11:32 zyong File Added: remote_log
2013-05-18 21:30 derick Note Added: 0002473
2013-05-18 21:30 derick Assigned To => derick
2013-05-18 21:30 derick Status new => feedback
2013-05-21 13:23 zyong Note Added: 0002478
2013-05-21 13:23 zyong Status feedback => assigned
2014-02-27 19:50 derick Note Added: 0002716
2014-02-27 19:50 derick Status assigned => feedback
2014-02-28 01:47 zyong Note Added: 0002729
2014-02-28 01:47 zyong Status feedback => assigned
2014-03-02 14:20 derick Note Added: 0002734
2014-03-02 14:20 derick Status assigned => resolved
2014-03-02 14:20 derick Resolution open => unable to reproduce
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)