View Issue Details

IDProjectCategoryView StatusLast Update
0000953XdebugUsage problems (Wrong Results)public2013-06-22 13:02
ReporterspellerAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformOSWindowsOS Version7
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000953: Can not debug arrays which keys contain zero characters
DescriptionIf a program contain arrays which keys contain zero characters \0. For example, such arrays become available when you cast object to array when object is instance of a class from a namespace.

Sample code 1:
namespace aaa\aaa;
class cls {
    private $field;
}
$a = new cls();
$a = (array)$a;
if ($a) {}


Sample code 2:
$a = ["aa\0aa\0aa" => 'value'];
if ($a) {}
Steps To Reproduce1. Create a php file with code from Sample 1 or Sample 2.
2. Place brakepoint to the "if ($a) {}" line.
3. Start debugging.

What is expected:
Debugging stops on the breakpoint.

What is actually accurs:
Debugging stops on the breakpoint but debugging session cancels immediately. Program execution continues successfully.
Additional InformationYou can also try to place brakepoint one line earlier and you will get normal behavior, debugger will stop and show you all information. But when you will try to step to next line where $a become initialized with array you will lost debugging session immediately.

Tested on PHP versions 5.3.8 and 5.4.7.
TagsNo tags attached.
Operating SystemWindows 7
PHP Version5.3.8

Relationships

duplicate of 0000924 resolvedderick $test = array("\0" => ''); renders variable view inoperable 

Activities

derick

2013-06-22 13:02

administrator   ~0002507

A duplicate of 924.

Issue History

Date Modified Username Field Change
2013-06-20 02:36 speller New Issue
2013-06-22 13:02 derick Note Added: 0002507
2013-06-22 13:02 derick Relationship added duplicate of 0000924
2013-06-22 13:02 derick Status new => resolved
2013-06-22 13:02 derick Resolution open => duplicate
2013-06-22 13:02 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)