View Issue Details

IDProjectCategoryView StatusLast Update
0000956XdebugInstallationpublic2016-12-23 21:25
ReportersubbsdAssigned Toderick 
PrioritynormalSeveritytrivialReproducibilityalways
Status resolvedResolutionno change required 
Platformamd64OSFreeBSDOS Version10.0-current
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000956: small notes from LLVM/CLANG compilers about xdebug code
DescriptionWhen compiling xdebug by LLVM (for example on FreeBSD-head), compilers produce this warning:

...
 cc -I. -I/usr/home/oleg/php-xdebug/work/xdebug-2.2.3 -DPHP_ATOM_INC -I/usr/home/oleg/php-xdebug/work/xdebug-2.2.3/include -I/usr/home/oleg/php-xdebug/work/xdebug-2.2.3/main -I/usr/home/oleg/php-xdebug/work/xdebug-2.2.3 -I/usr/local/include/php -I/usr/local/include/php/main -I/usr/local/include/php/TSRM -I/usr/local/include/php/Zend -I/usr/local/include/php/ext -I/usr/local/include/php/ext/date/lib -DHAVE_CONFIG_H -O2 -pipe -fno-strict-aliasing -c /usr/home/oleg/php-xdebug/work/xdebug-2.2.3/xdebug_handler_dbgp.c -fPIC -DPIC -o .libs/xdebug_handler_dbgp.o
/usr/home/oleg/php-xdebug/work/xdebug-2.2.3/xdebug_handler_dbgp.c:1310:21: warning: incompatible pointer types initializing 'jmp_buf *' (aka 'struct _jmp_buf (*)[1]') with an expression of type 'sigjmp_buf *' (aka 'struct _sigjmp_buf (*)[1]')
      [-Wincompatible-pointer-types]
        jmp_buf *original_bailout = EG(bailout);
                           ^ ~~~~~~~~~~~
/usr/home/oleg/php-xdebug/work/xdebug-2.2.3/xdebug_handler_dbgp.c:1345:14: warning: incompatible pointer types assigning to 'sigjmp_buf *' (aka 'struct _sigjmp_buf (*)[1]') from 'jmp_buf *' (aka 'struct _jmp_buf (*)[1]') [-Wincompatible-pointer-types]
        EG(bailout) = original_bailout;
                    ^ ~~~~~~~~~~~~~~~~
/usr/home/oleg/php-xdebug/work/xdebug-2.2.3/xdebug_handler_dbgp.c:2003:28: warning: passing 'const char *' to parameter of type 'char *' discards qualifiers [-Wincompatible-pointer-types-discards-qualifiers]
        xdebug_hash_add(tmp_hash, hash_key->arKey, strlen(hash_key->arKey), hash_key->arKey);
                                  ^~~~~~~~~~~~~~~
./xdebug_hash.h:75:74: note: expanded from macro 'xdebug_hash_add'
#define xdebug_hash_add(h, key, key_len, p) xdebug_hash_add_or_update(h, key, key_len, 0, p)
                                                                         ^
./xdebug_hash.h:66:54: note: passing argument to parameter 'str_key' here
int xdebug_hash_add_or_update(xdebug_hash *h, char *str_key, unsigned int str_key_len, unsigned long num_key, const void *p);
                                                     ^
3 warnings generated.
...
Steps To Reproducemake -C /usr/ports/devel/php-xdebug install

on FreeBSD or on any LLVM-based distros
Additional Informationxdebug working well, its just notice
TagsNo tags attached.
Operating SystemFreeBSD
PHP Version5.1.0

Activities

derick

2016-11-28 20:14

administrator   ~0003813

I can't reproduce this with PHP 5.5.29-dev and CLANG 3.8.1-16 as used on Debian Sid.

Can you still reproduce this issue?

derick

2016-12-23 21:25

administrator   ~0004096

Closing this, as the requested feedback whether it's still a problem wasn't answered. Please reopen this issue if necessary.

Issue History

Date Modified Username Field Change
2013-07-03 15:44 subbsd New Issue
2016-11-28 20:14 derick PHP Version 5.5-dev => 5.1.0
2016-11-28 20:14 derick Note Added: 0003813
2016-11-28 20:14 derick Assigned To => derick
2016-11-28 20:14 derick Status new => feedback
2016-12-23 21:25 derick Note Added: 0004096
2016-12-23 21:25 derick Status feedback => resolved
2016-12-23 21:25 derick Resolution open => no change required