View Issue Details

IDProjectCategoryView StatusLast Update
0000966XdebugUsage problems (Wrong Results)public2014-05-19 23:18
ReportervmusAssigned Toderick 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionunable to reproduce 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000966: Unable to debug DomDocument
DescriptionAs per http://bugs.xdebug.org/view.php?id=913 ; http://bugs.xdebug.org/view.php?id=910 and http://stackoverflow.com/questions/17110648/debugging-domdocument-php-with-xdebug-var-dump-not-showing-properties
Steps To Reproduce$DOMDocumentNode = new DOMDocument();
$DOMDocumentNode->loadXML('<example a="b">Test</example>');
$DOMElementNode = $DOMDocumentNode->documentElement;
$DOMAttributeNode = $DOMElementNode->getAttributeNode('a');
$DOMTextNode = $DOMElementNode->firstChild;

error_reporting(0);
var_dump($DOMDocumentNode, $DOMElementNode, $DOMAttributeNode, $DOMTextNode);

Additional InformationTested on Fedora 18 and 19 (remi repo, php 5.5, xdebug 2.2.3) Windows 7 Pro with xampp, Ubuntu 12.04 LTS (ondrej ppa) with default settings.

Ubuntu 12.04 xdebug settings:

Directive Local Value Master Value
xdebug.auto_trace Off Off
xdebug.cli_color 0 0
xdebug.collect_assignments Off Off
xdebug.collect_includes On On
xdebug.collect_params 0 0
xdebug.collect_return Off Off
xdebug.collect_vars Off Off
xdebug.coverage_enable On On
xdebug.default_enable On On
xdebug.dump.COOKIE no value no value
xdebug.dump.ENV no value no value
xdebug.dump.FILES no value no value
xdebug.dump.GET no value no value
xdebug.dump.POST no value no value
xdebug.dump.REQUEST no value no value
xdebug.dump.SERVER no value no value
xdebug.dump.SESSION no value no value
xdebug.dump_globals On On
xdebug.dump_once On On
xdebug.dump_undefined Off Off
xdebug.extended_info On On
xdebug.file_link_format no value no value
xdebug.idekey no value no value
xdebug.max_nesting_level 100 100
xdebug.overload_var_dump On On
xdebug.profiler_aggregate Off Off
xdebug.profiler_append Off Off
xdebug.profiler_enable Off Off
xdebug.profiler_enable_trigger Off Off
xdebug.profiler_output_dir /tmp /tmp
xdebug.profiler_output_name cachegrind.out.%p cachegrind.out.%p
xdebug.remote_autostart Off Off
xdebug.remote_connect_back Off Off
xdebug.remote_cookie_expire_time 3600 3600
xdebug.remote_enable Off Off
xdebug.remote_handler dbgp dbgp
xdebug.remote_host localhost localhost
xdebug.remote_log no value no value
xdebug.remote_mode req req
xdebug.remote_port 9000 9000
xdebug.scream Off Off
xdebug.show_exception_trace Off Off
xdebug.show_local_vars Off Off
xdebug.show_mem_delta Off Off
xdebug.trace_enable_trigger Off Off
xdebug.trace_format 0 0
xdebug.trace_options 0 0
xdebug.trace_output_dir /tmp /tmp
xdebug.trace_output_name trace.%c trace.%c
xdebug.var_display_max_children 128 128
xdebug.var_display_max_data 512 512
xdebug.var_display_max_depth 3 3
TagsNo tags attached.
Operating SystemUbuntu 12.04 LTS
PHP Version5.5-dev

Activities

derick

2013-07-23 10:46

administrator   ~0002540

I can still not reproduce this :S Does it work if you compile your own Xdebug through PECL?

I'd love to help, perhaps you can provide access to your machine and make sure strace, gdb and all the sources are in the right spots?

vmus

2013-07-23 18:17

reporter   ~0002546

Last edited: 2013-07-23 18:19

View 2 revisions

On the 12.04 I'm running 2.2.3 compiled from PEAR, as per your suggestion on stackoverflow.

But anytime we can agree I can provide you access via Teamviewer. I'm on EEST time zone, so only 1hr difference from NL :)

derick

2013-07-29 09:10

administrator   ~0002548

I've no idea what TeamViewer is - can't you provide SSH access? I'm also not in NL but in the UK.

vmus

2013-08-12 08:01

reporter   ~0002554

derick, can you contact me on my e-mail, so we can arrange it?

derick

2013-09-28 13:15

administrator   ~0002565

Sorry, I dropped the ball on this. You can email me at derick@xdebug.org

derick

2014-02-27 19:57

administrator   ~0002720

And again... You can email me at derick@xdebug.org please? :-)

derick

2014-05-19 23:18

administrator   ~0002825

I'm closing this as I can not reproduce it, but feel free to reopen this after you sent me that email.

Issue History

Date Modified Username Field Change
2013-07-22 17:51 vmus New Issue
2013-07-23 10:46 derick Note Added: 0002540
2013-07-23 10:46 derick Assigned To => derick
2013-07-23 10:46 derick Status new => feedback
2013-07-23 18:17 vmus Note Added: 0002546
2013-07-23 18:17 vmus Status feedback => assigned
2013-07-23 18:19 vmus Note Edited: 0002546 View Revisions
2013-07-29 09:10 derick Note Added: 0002548
2013-08-12 08:01 vmus Note Added: 0002554
2013-09-28 13:15 derick Note Added: 0002565
2014-02-27 19:57 derick Note Added: 0002720
2014-02-27 19:57 derick Status assigned => feedback
2014-05-19 23:18 derick Note Added: 0002825
2014-05-19 23:18 derick Status feedback => resolved
2014-05-19 23:18 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)