View Issue Details

IDProjectCategoryView StatusLast Update
0000967XdebugInstallationpublic2014-02-27 19:56
ReportermdegalliAssigned Toderick 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000967: Won't install with PHP 5.4.17
DescriptionKeep getting this error:

Xdebug requires Zend Engine API version 220090626.
The Zend Engine API version 220100525 which is installed, is newer.
Contact Derick Rethans at http://xdebug.org/docs/faq#api for a later version of Xdebug.

(I have the latest version)

Which xdebug version should I use?
Steps To ReproduceTailored Installation Instructions

Summary

Xdebug installed: no
Server API: CGI/FastCGI
Windows: no
Zend Server: no
PHP Version: 5.4.17
Zend API nr: 220100525
PHP API nr: 20100525
Debug Build: no
Thread Safe Build: no
Configuration File Path: /usr/local/lib
Configuration File: /usr/local/lib/php.ini
Extensions directory: /usr/local/lib/php/extensions/no-debug-non-zts-20100525
Instructions

Download xdebug-2.2.3.tgz
Unpack the downloaded file with tar -xvzf xdebug-2.2.3.tgz
Run: cd xdebug-2.2.3
Run: phpize (See the FAQ if you don't have phpize.

As part of its output it should show:

Configuring for:
...
Zend Module Api No: 20100525
Zend Extension Api No: 220100525
If it does not, you are using the wrong phpize. Please follow this FAQ entry and skip the next step.

Run: ./configure
Run: make
Run: cp modules/xdebug.so /usr/local/lib/php/extensions/no-debug-non-zts-20100525
Edit /usr/local/lib/php.ini and add the line
zend_extension = /usr/local/lib/php/extensions/no-debug-non-zts-20100525/xdebug.so
Restart the webserver
Additional InformationSystem Linux

Configure Command './configure' '--disable-fileinfo' '--enable-bcmath' '--enable-calendar' '--enable-ftp' '--enable-gd-native-ttf' '--enable-libxml' '--enable-pdo=shared' '--enable-sockets' '--prefix=/usr/local' '--with-apxs2=/usr/local/apache/bin/apxs' '--with-curl=/opt/curlssl/' '--with-freetype-dir=/usr' '--with-gd' '--with-imap=/opt/php_with_imap_client/' '--with-imap-ssl=/usr' '--with-jpeg-dir=/usr' '--with-kerberos' '--with-libdir=lib64' '--with-libxml-dir=/opt/xml2/' '--with-mcrypt=/opt/libmcrypt/' '--with-mysql=/usr' '--with-mysql-sock=/var/lib/mysql/mysql.sock' '--with-openssl=/usr' '--with-openssl-dir=/usr' '--with-pcre-regex=/opt/pcre' '--with-pdo-mysql=shared' '--with-pdo-sqlite=shared' '--with-pic' '--with-png-dir=/usr' '--with-xpm-dir=/usr' '--with-zlib' '--with-zlib-dir=/usr'
Server API CGI/FastCGI
Virtual Directory Support disabled
Configuration File (php.ini) Path /usr/local/lib
Loaded Configuration File /usr/local/lib/php.ini
Scan this dir for additional .ini files (none)
Additional .ini files parsed (none)
PHP API 20100412
PHP Extension 20100525
Zend Extension 220100525
Zend Extension Build API220100525,NTS
PHP Extension Build API20100525,NTS
Debug Build no
Thread Safety disabled
Zend Signal Handling disabled
Zend Memory Manager enabled
Zend Multibyte Support disabled
IPv6 Support enabled
DTrace Support disabled
Registered PHP Streams https, ftps, compress.zlib, php, file, glob, data, http, ftp, phar
Registered Stream Socket Transports tcp, udp, unix, udg, ssl, sslv3, sslv2, tls
Registered Stream Filters zlib.*, convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk

Zend logo This program makes use of the Zend Scripting Language Engine:
Zend Engine v2.4.0, Copyright (c) 1998-2013 Zend Technologies
TagsNo tags attached.
Operating SystemApache/2.2.24 (Unix)
PHP Version5.4.10-5.4.14

Activities

derick

2013-07-23 08:14

administrator   ~0002539

This is not a bug, please refer to the FAQ: http://xdebug.org/docs/faq#api

mdegalli

2013-07-23 20:00

reporter   ~0002547

I've done everything the FAQ asks and the versions match up. What else is wrong?

FROM PHPIZE:
root@hosting [/home/xdebug-2.2.3]# phpize
Configuring for:
PHP Api Version: 20100412
Zend Module Api No: 20100525
Zend Extension Api No: 220100525

FROM PHPINFO():
PHP API 20100412
PHP Extension 20100525
Zend Extension 220100525

FROM PHP-CONFIG:
root@hosting [/usr/bin]# php-config --version
5.4.17

mdegalli

2013-07-30 21:20

reporter   ~0002549

Which xdebug version should I use?

mdegalli

2013-08-02 21:45

reporter   ~0002550

FYI, finally got it working after a week of struggle:

Just use "pecl install xdebug" at the command line!

 ... the wizard just doesn't work for me. I thought since I'm not a Linux/Admin guru the wizard would be the easiest ... but the above command did the trick.

derick

2014-02-27 19:56

administrator   ~0002719

I'm glad it works! Closing out this issue.

Issue History

Date Modified Username Field Change
2013-07-22 22:57 mdegalli New Issue
2013-07-23 08:14 derick Note Added: 0002539
2013-07-23 08:14 derick Status new => resolved
2013-07-23 08:14 derick Resolution open => no change required
2013-07-23 08:14 derick Assigned To => derick
2013-07-23 20:00 mdegalli Note Added: 0002547
2013-07-23 20:00 mdegalli Status resolved => feedback
2013-07-23 20:00 mdegalli Resolution no change required => reopened
2013-07-30 21:20 mdegalli Note Added: 0002549
2013-07-30 21:20 mdegalli Status feedback => assigned
2013-08-02 21:45 mdegalli Note Added: 0002550
2014-02-27 19:56 derick Note Added: 0002719
2014-02-27 19:56 derick Status assigned => resolved
2014-02-27 19:56 derick Resolution reopened => no change required