View Issue Details

IDProjectCategoryView StatusLast Update
0000098XdebugUsage problems (Wrong Results)public2004-11-04 23:20
Reportere_v_chesAssigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionopen 
Product Version 
Target VersionFixed in Version 
Summary0000098: 'longname' attribute not returned for property in context_get request
Descriptioncode in PHP:
function xxx() {
    for($i=$_COOKIE;$i<100;$i++)
        echo "$i aaa";
}
when on breakpoint on 'for' line, request is:
context_get -i 57 -c 0 -d 0
response is:
<response command="context_get" transaction_id="57"><property name="i" type="uninitialized"></property><property name="_COOKIE" fullname="$_COOKIE" address="4629936" type="array" children="0" numchildren="0"></property></response>

So the problem is there's no 'fullname' attribute for 'i' property.
 Thanks in advance.
TagsNo tags attached.
Operating SystemMacOSX
PHP Version4.3.0

Activities

derick

2004-11-04 23:20

administrator   ~0000206

Fixed in CVS.

Issue History

Date Modified Username Field Change
2004-11-02 14:55 e_v_ches New Issue
2004-11-04 23:20 derick Status new => closed
2004-11-04 23:20 derick Note Added: 0000206
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)