View Issue Details

IDProjectCategoryView StatusLast Update
0000981XdebugUsage problems (Wrong Results)public2014-06-18 12:31
ReporterisimmonsAssigned Toderick 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformwindows OSwindows 7 pro 64bitOS Version
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000981: php cli extremely long delay when xdebug extension loaded
DescriptionWith versions 2.2.0 through 2.2.3 of xdebug, when the extension is loaded any Laravel artisan commands have about a 20 second delay. Composer install or update can take hours. I actually have not waited more than one hour but with composer --verbose turned on can see it actually is running but it never completes.

I have tried setting
xdebug.remote_enable=0
xdebug.remote_autostart=0

But the only way to stop the performance hit is to comment out the zend_extension to stop it loading completely.

Steps To ReproduceInstall any xdebug extension 2.2.0 - 2.2.3
enable the extension loading in php.ini
Install composer and try to use it to install Laravel framework.

Or with extension not loaded
Intall Laravel Framework
Then load the extension
Try to run "php artisan" from the laravel directory.
Additional InformationI created a batch file for composer to load a different noxdebug.ini when it is running but can't do this or don't know how to do this for the php cli.

Actually doesn't occur for running built in commands like php -i or php -v

Only when running a script via cli

php version is 5.4.16 but not available in dropdown so checked closest thing.
TagsNo tags attached.
Operating SystemWindows 7 Pro 64bit
PHP Version5.4.10-5.4.14

Activities

derick

2013-12-04 00:22

administrator   ~0002637

Sorry, but "Install laravel" is not something I am going to want to do. Please make a trace file (http://xdebug.org/docs/execution_trace) and attach it. Perhaps you can have a look yourself where you see a large discrepancy in time too.

derick

2014-03-05 09:18

administrator   ~0002746

Closing this out, as no feedback is provided. Feel free to reopen this if you can provide the requested feedback.

Issue History

Date Modified Username Field Change
2013-10-01 23:11 isimmons New Issue
2013-12-04 00:22 derick Note Added: 0002637
2013-12-04 00:22 derick Assigned To => derick
2013-12-04 00:22 derick Status new => feedback
2014-03-05 09:18 derick Note Added: 0002746
2014-03-05 09:18 derick Status feedback => resolved
2014-03-05 09:18 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)