View Issue Details

IDProjectCategoryView StatusLast Update
0000984XdebugUsage problems (Wrong Results)public2014-03-05 09:18
ReporteralesakAssigned Toderick 
PrioritynormalSeverityblockReproducibilityalways
Status resolvedResolutionunable to reproduce 
Platformx64OSLinuxOS Version3.11.4
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000984: SIGSERV 11 xbuf_format_converter use of undefined constant %s
DescriptionSome request are failing with this exception. Debugging showed some problems subj called by vspprintf in xdebug_stack.c probably on line 550

buffer_len = vspprintf(&buffer, PG(log_errors_max_len), format, args);
Steps To ReproduceIf necessary I can try to make some reproducible script but right now I don't know what exactly is causing it. It was introduced by commit 08371460165ae95b63abd7aa0823b29e913dfa1d into XDEBUG_2_2 branch.
Additional Informationcommit 1d169f6c58eef9da299529491002b39fee88ce7a is still OK

commit 08371460165ae95b63abd7aa0823b29e913dfa1d is failing

tried PHP 5.4.12, 5.4.20 and it looks same
TagsNo tags attached.
Operating SystemLinux
PHP Version5.4-dev

Activities

patrickallaert

2013-10-11 08:24

reporter   ~0002577

@alesak: Can you test that this following PR solves the issue?

https://github.com/xdebug/xdebug/pull/83

alesak

2013-10-15 07:43

reporter   ~0002593

It didn't help I am afraid

derick

2013-12-04 00:04

administrator   ~0002633

All right - can I then please ask you to come up with a small script that I can run?

derick

2014-03-05 09:18

administrator   ~0002744

Closing this out, as no feedback is provided. Feel free to reopen this if you can provide the requested feedback.

Issue History

Date Modified Username Field Change
2013-10-09 06:49 alesak New Issue
2013-10-11 08:24 patrickallaert Note Added: 0002577
2013-10-15 07:43 alesak Note Added: 0002593
2013-12-04 00:04 derick Note Added: 0002633
2013-12-04 00:04 derick Assigned To => derick
2013-12-04 00:04 derick Status new => feedback
2014-03-05 09:18 derick Note Added: 0002744
2014-03-05 09:18 derick Status feedback => resolved
2014-03-05 09:18 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)