View Issue Details

IDProjectCategoryView StatusLast Update
0000992Xdebug(No Category)public2014-03-05 09:17
ReporterchrislondonAssigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionduplicate 
PlatformMacbook ProOSOS XOS Version10.8.4
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000992: Incomplete Code Coverage
DescriptionI'm unable to get complete code coverage in PHPUnit. It appears xdebug is reporting that "break;" and "$var++;" are executable but aren't being executed. I don't think this is a PHPUnit issue.
Steps To Reproduce- Set up PHPUnit to use xDebug for code coverage.
- Create a test that includes a switch statement with breaks and/or a line that uses a ++;
Additional InformationUsing:
 PHP_CodeCoverage 1.2.13
 PHP 5.4.16
 PHPUnit 3.7.28
TagsNo tags attached.
Operating System
PHP Version5.4.10-5.4.14

Activities

chrislondon

2013-10-25 15:23

reporter  

Feedback_src_Feedback_CodeCoverage.php.html (16,766 bytes)

chrislondon

2013-10-25 15:35

reporter  

xdebugissue.zip (24,970 bytes)

jrhernandez84

2013-11-19 13:29

reporter   ~0002617

This is the exact bug I reported at http://bugs.xdebug.org/view.php?id=939 .

derick

2013-12-03 22:15

administrator   ~0002627

I can't reproduce this, it works just fine for me: http://derickrethans.nl/files/cov/BreakSample.php.html

I'm using PHP_CodeCoverage 1.2.13 using PHP 5.4.24-dev and PHPUnit 3.7.28 and Xdebug v2.2.4dev

Are you perhaps using an opcode cache, or another PHP version? Can you provide your phpinfo output in a text file?

Issue History

Date Modified Username Field Change
2013-10-25 15:23 chrislondon New Issue
2013-10-25 15:23 chrislondon File Added: Feedback_src_Feedback_CodeCoverage.php.html
2013-10-25 15:35 chrislondon File Added: xdebugissue.zip
2013-11-19 13:29 jrhernandez84 Note Added: 0002617
2013-12-03 22:15 derick Note Added: 0002627
2013-12-03 22:15 derick Assigned To => derick
2013-12-03 22:15 derick Status new => feedback
2014-03-05 09:17 derick Status feedback => resolved
2014-03-05 09:17 derick Resolution open => duplicate
2016-07-31 12:35 derick Category Debug client (console) => debugclient (debugging tool)
2016-07-31 12:35 derick Category debugclient (debugging tool) => (No Category)