View Issue Details

IDProjectCategoryView StatusLast Update
0000999XdebugUsage problems (Wrong Results)public2014-03-05 09:17
ReporterkenorbAssigned Toderick 
PrioritynormalSeveritycrashReproducibilityalways
Status resolvedResolutionunable to reproduce 
PlatformMacOSOSXOS Version10.9
Product Version2.2.3 
Target VersionFixed in Version 
Summary0000999: SEGV at xdebug_zval_ptr + 50 (xdebug_compat.c:93) in CLI
DescriptionProcess: php [63066]
Path: /Applications/MAMP/*/php
Code Type: X86-64 (Native)
Parent Process: bash [43209]
Responsible: Terminal [800]
User ID: 501

Date/Time: 2013-11-05 15:33:59.023 +0000
OS Version: Mac OS X 10.9 (13A3017)
Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x0000000000000014

Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0 xdebug.so 0x00000001018cef82 xdebug_zval_ptr + 50 (xdebug_compat.c:93)
1 xdebug.so 0x00000001018cc7d0 xdebug_execute_internal + 528 (xdebug.c:1592)
2 php 0x0000000100659c78 zend_call_function + 5768
3 php 0x00000001004d4f5e zif_array_filter + 382
4 php 0x00000001006bf220 execute_internal + 240
5 xdebug.so 0x00000001018cc754 xdebug_execute_internal + 404 (xdebug.c:1577)
6 php 0x00000001006c2fee zend_do_fcall_common_helper_SPEC + 1678
7 php 0x00000001006cbc10 ZEND_DO_FCALL_SPEC_CONST_HANDLER + 400

This is probably related:
https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=999237

So the other full backtrace can be found at:
https://bugzilla.redhat.com/attachment.cgi?id=788678

Steps To ReproduceUsing CLI:

$ drush -l my.local -v updb
Initialized Drupal 7.23 root directory
Initialized Drupal site at my.local
Segmentation fault: 11

Additional InformationPHP: 5.5.3
XDebug compiled from master.
commit 7d491db2b6f5f62f855df3606380a1af01a9a5e6
Date: Sun Oct 13 19:48:02 2013 -0500

uname -a
Darwin Rafals-MacBook-Pro.local 13.0.2 Darwin Kernel Version 13.0.2: Sun Sep 29 19:38:57 PDT 2013; root:xnu-2422.75.4~1/RELEASE_X86_64 x86_64

This happening only when xdebug.auto_trace=1
I've increased xdebug.max_nesting_level to 200, but without the difference.

Last two lines from the xtrace file:

    4.9165 3029304 -> array_filter(array (':cids' => array (0 => 'variables')), 'is_array') database/database.inc:734
    4.9165 3029448 -> is_array(array (0 => 'variables')) includes/database/database.inc:734
TagsNo tags attached.
Operating SystemOSX
PHP Version5.5-dev

Activities

kenorb

2013-11-05 15:46

reporter  

php_2013-11-05-153359_Rafals-MacBook-Pro.crash (30,732 bytes)

kenorb

2013-11-05 15:50

reporter   ~0002600

Last edited: 2013-11-05 16:07

View 2 revisions

Possible crashing code:
    foreach (array_filter($args, 'is_array') as $key => $data) {
      $new_keys = array();
      foreach ($data as $i => $value) {
        $new_keys[$key . '_' . $i] = $value;
      }
...

But when commented out this block, it crashes again in the following lines:
-> array_map('unserialize', array (...)) includes/bootstrap.inc:919
-> unserialize('s:13:"menu-top-menu";') includes/bootstrap.inc:919

kenorb

2013-11-05 16:14

reporter   ~0002602

Tested the same thing with PHP 5.4.19 (cli) with Xdebug v2.2.3 and it works fine.

kenorb

2013-11-06 14:40

reporter   ~0002603

Two other crashes near array_filter()

1.
-> array_filter(array (':db_condition_placeholder_0' => 'taxonomy', ':db_condition_placeholder_1' => 1, ':db_condition_placeholder_2' => 1), 'is_array') includes/database/database.inc:734
-> is_array('taxonomy') includes/database/database.inc:734

2.
-> array_filter(array (':type' => 'module', ':name' => 'file'), 'is_array') includes/database/database.inc:73
-> is_array('module') includes/database/database.inc:734

derick

2013-12-04 00:02

administrator   ~0002631

Can you provide a small sample that is ready for me to run perhaps?

derick

2014-03-05 09:17

administrator   ~0002743

Closing this out, as no feedback is provided. Feel free to reopen this if you can provide the requested feedback.

Issue History

Date Modified Username Field Change
2013-11-05 15:45 kenorb New Issue
2013-11-05 15:46 kenorb File Added: php_2013-11-05-153359_Rafals-MacBook-Pro.crash
2013-11-05 15:50 kenorb Note Added: 0002600
2013-11-05 16:07 kenorb Note Edited: 0002600 View Revisions
2013-11-05 16:14 kenorb Note Added: 0002602
2013-11-06 14:40 kenorb Note Added: 0002603
2013-12-04 00:02 derick Note Added: 0002631
2013-12-04 00:02 derick Assigned To => derick
2013-12-04 00:02 derick Status new => feedback
2014-03-05 09:17 derick Note Added: 0002743
2014-03-05 09:17 derick Status feedback => resolved
2014-03-05 09:17 derick Resolution open => unable to reproduce
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)