View Issue Details

IDProjectCategoryView StatusLast Update
0001041XdebugUsage problems (Wrong Results)public2014-06-21 21:51
Reporteraik099Assigned Toderick 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
PlatformOSSlackware LinuxOS Version13.37
Product Version2.2.4 
Target VersionFixed in Version 
Summary0001041: Dead code reported after "return" and "throw"
DescriptionBefore PHPUnit wasn't highlighting dead code properly. Now it does (yellow lines) and I don't know why every closing brace after "throw" or "return" statement is considered as a dead code (see image).
TagsNo tags attached.
Operating System
PHP Version5.4.20-5.4.24

Activities

aik099

2014-03-23 11:39

reporter  

PhpUnit_DeadCode.png (100,489 bytes)
PhpUnit_DeadCode.png (100,489 bytes)

derick

2014-06-21 21:51

administrator   ~0002853

Hi.

Lots of people have asked me, and this is not a bug. I've written a lengthy explanation at http://drck.me/deadcode-azx

cheers,
Derick

Issue History

Date Modified Username Field Change
2014-03-23 11:39 aik099 New Issue
2014-03-23 11:39 aik099 File Added: PhpUnit_DeadCode.png
2014-06-21 21:51 derick Note Added: 0002853
2014-06-21 21:51 derick Status new => resolved
2014-06-21 21:51 derick Resolution open => no change required
2014-06-21 21:51 derick Assigned To => derick
2016-07-31 12:36 derick Category Usage problems => Usage problems (Crashes)
2016-07-31 12:38 derick Category Usage problems (Crashes) => Usage problems (Wrong Results)